UVA 10110 (13.07.26)

Light,more light

The Problem

There is man named "mabu" for switching on-off light in our University.He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption(or may be he is mad or something else) he does a peculiar thing. If ina corridor there is `n' bulbs, he walks along the corridor back and forth`n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position.A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less thenor equals 2^32-1. A zero indicates the end of input. You should not processthis input.

The Output

Output " yes" if the light is on otherwise " no" , in a single line.

SampleInput

3
6241
8191
0

SampleOutput

no
yes
no

题意:一个走廊上有n, 开始是全部关闭状态
一个神经病, 走n走廊, 假如n是6, 那么6的因子数有1, 2, 3, 6. 那么走四次, 第一次每隔1盏灯就转化对应灯状态, 第二次每隔2盏灯转化状态, 类推~ 那么很容易看出来, n盏灯, 除非是平方数, 不然其因子数是成对出现, 如6中的 1和6, 2和3 而平方数多了一个开方的因子数, 其因子数就变成了奇数个, 从而状态改变就是由开始的关变为了开 注意:用int, 理论上可行, 实际上我WA了, 改用long long过了 做法:不说了...  AC代码: 
#include<stdio.h>
#include<math.h>

int main() {
	long long n, k;
	while(scanf("%lld", &n) != EOF) {
		if(n == 0)
			break;
		k = sqrt(n);
		if(k * k == n)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值