PAT 1033. To Fill or Not to Fill (25)(加油问题)(待修改)

官网

1033. To Fill or Not to Fill (25)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,…N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

题目大意

  • 1.给出这条道路上每个车站的距离和油的价格,问在这条路上走D米能不能走到,能走到的话花的最小的钱是多少。

解题思路

  • 1.油箱分层,最贵的放下面,最便宜的放上面,每次消耗最便宜的油,每到一个车站就计算走过的路径以及cost,并且把油箱里面贵的油换这个车站的油并加满,这样就保证了cost最小了,因为每次都消耗的是最便宜的油了啊~

待修改代码(有一个节点段错误,之前写过的代码好像都对了,重写反而错了)

#include<iostream>
#include<algorithm>
#include<vector>
#include<map>
#include<deque>
#include<cstdio>
using namespace std;
struct station {
    double p,s;

};
bool cmp_sta(const station &a,const station &b){
    return a.s < b.s;
}

struct tanck {
    double p,w;
    tanck(double _p,double _w):p(_p),w(_w){}
};
int main(int argc, char *argv[])
{
    double cmax,d,davg,longest;int n;
    cin >> cmax >> d >> davg >> n ;
    longest = cmax * davg;
    vector<station> sta(n+1);
    for (int i = 0; i < n; ++i) {
        cin >> sta[i].p >> sta[i].s;
    }
    sta[n].s = d; sta[n].p = 0;
    sort(sta.begin(),sta.end(),cmp_sta);
    //
    deque<tanck> tan;
    double now = 0,total_keep = 0,cost = 0;
    for (int i = 0; i <= n; ++i) {
        if (sta[i].s - now > longest) {
            now += longest;
        }
        else if (sta[i].s - now <= longest) {
            //消耗油
            double tem_oil,tem_s;
            tem_s = sta[i].s - now;
            tem_oil = tem_s / davg;
            while (tem_oil > 0) {
                tanck tem_top = tan.front();
                //考察第一层油够不够
                if (tem_top.w > tem_oil) {
                    tem_top.w -= tem_oil;
                    total_keep -= tem_oil;
                    cost += tem_oil * tem_top.p;
                    tan.pop_front();
                    tan.push_front(tem_top);
                    tem_oil = 0;
                }else {
                    tem_oil -= tem_top.w;
                    cost += tem_top.w * tem_top.p;
                    tan.pop_front();
                    total_keep -= tem_top.w;

                }
            }
            //更新now
            now  = sta[i].s;
            //把比他贵的油排出来并加满油
            while (!tan.empty() ) {
                tanck tem_back  = tan.back();
                if (tem_back.p <= sta[i].p) {
                    break;
                }else {
                    total_keep -= tem_back.w;
                    tan.pop_back();
                }
            }
            //加满油
            if (total_keep < cmax) {
                tan.push_back(tanck(sta[i].p,cmax - total_keep));
                total_keep = cmax;
            }
        }
    }
    if (now != d) {
        printf("The maximum travel distance = %.2f\n",now);
    }else {
        printf("%.2f\n",cost);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值