PAT 1059. Prime Factors (25)(分解质因数)

官网

1059. Prime Factors (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming
Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

解题思路

  • 1.题目要求将一个数分解质因数并打印出来。
  • 2.从小到大求质因数,保存上一个质因数,这样求下一个质因数就可以从这个数开始算了,避免重复。

AC代码

#include<iostream>
#include<math.h>
#include<map>
using namespace std;
map<int,int> p;
int isPrime(int a,int fomer){
    for (int i = fomer; i <= sqrt(a); ++i) {
        if (a % i == 0) {
            return i;
        }
    }
    return 0;
}

int main(int argc, char *argv[])
{
    int n;
    cin >> n;
    int tem_n = n;
    int fomer =2;
    while (1) {
    //记录上一个质因数
        fomer = isPrime(n,fomer);
        if (fomer == 0) {
            if (p.find(n)==p.end()) {
                p[n] = 1;
            }else {
                p[n]++;
            }
            break;
        }
        //把所有质因数保存在p中
        if (p.find(fomer)==p.end()) {
            p[fomer] = 1;
        }else {
            p[fomer]++;
        }
        n = n / fomer;
    }
    //打印
    map<int,int>::iterator it;
    cout << tem_n << "=";
    for(it = p.begin();it!=p.end();it++){
        if (it == p.begin()) {
            cout << it->first ;
            if (it->second>1) {
                cout << "^"<<it->second;
            }
        }else {
            cout << "*" << it->first ;
            if (it->second>1) {
                cout << "^"<<it->second;
            }
        }
    }
    cout << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值