POJ - 3122 Pie

Pie
Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.  

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.  

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10   −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

二分

#include<iostream>
#include<iomanip>
#include<cstdio>
using namespace std;
const double Pi = 3.14159265359;   //注意精度
const double esp = 1e-6;
int main()
{
	int casen;
	cin >> casen;
	while (casen--)
	{
		int n, f;
		double v[10005];          //每个pie的size
		scanf_s("%d%d", &n, &f);
		f++;

		double maxsize = 0.0;
		for (int i = 1; i <= n; i++)
		{
			scanf_s("%lf", &v[i]);
			v[i] = v[i] * v[i];
			if (v[i] > maxsize)        //求二分法的上界
				maxsize = v[i];
		}

		double high = maxsize;        //上界,每人都得到整个pie,而且那个pie为所有pie中最大的
		double low = 0.0;             //下界,每人都分不到pie
		double mid;

		while (high - low > esp)       //实数double的二分结束条件不同于整数int的二分结束条件
		{
			mid = (high + low) / 2;   //对当前上下界折中,计算"如果按照mid的尺寸分pie,能分给多少人"

			int count_f = 0;           //根据mid尺寸能分给的人数
			for (int i = 1; i <= n; i++)//枚举每个pie
				count_f += (int)(v[i] / mid);  //第i个pie按照mid的尺寸去切,最多能分的人数(取整)

			if (count_f < f)  //当用mid尺寸分,可以分的人数小于额定人数
				high = mid; //说明mid偏大,上界优化
			else 
				low = mid;  //否则mid偏小,下界优化(注意'='一定要放在下界优化,否则精度会出错)
		}
		cout << fixed << setprecision(4) << mid*Pi << endl; //之前的计算都只是利用半径平方去计算,最后的结果要记得乘pi
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值