POJ -3122 Pie(二分)

Pie

Time Limit: 1000MSMemory Limit: 65536K

Description
My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input
One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output
25.1327
3.1416
50.2655

题意:T个样例,每个样例包含两行,第一行pie的个数n,朋友数f,第二行n个pie各自的半径。所有派高度为1。主人和朋友分pie,每个人分的多少必须一样,不能吃碎渣(pie的总体积和/人数 不行,这样有的人会吃碎渣),问每个人最多分到多少。

二分分到的体积V

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
#include<vector>
using namespace std;

#define pi acos(-1)

int num(double x, double a[], int n)
{
    int s=0;//每块蛋糕都按V=x分割,s为可以分割几块
    for(int i=0; i<n; i++)
        s+=a[i]/x;
    return s;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, f;
        double sum=0, a[100005];
        scanf("%d%d", &n, &f);
        f++;//主人也加上
        for(int i=0; i<n; i++)
        {
            scanf("%lf", &a[i]);
            a[i]=pi*a[i]*a[i];//直接存体积
            sum+=a[i];//体积和
        }
        double l=0, r=sum/f, m;//每个人最多分到sum/f,即为二分的右边界r
        while(r-l>=1e-5)//注意精度
        {
            m=(l+r)/2.0;
            if(num(m, a, n)<f)//分到的蛋糕小于f,证明单个体积太大,m右边的不能要,r=m
                r=m;
            else//反之亦然
                l=m;
        }
        printf("%.4f\n", m);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值