hdu 5459 Jesus Is Here(推公式)

42 篇文章 0 订阅
20 篇文章 0 订阅

Jesus Is Here

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/102400 K (Java/Others)
Total Submission(s): 510    Accepted Submission(s): 366


Problem Description
I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is  s1=c"  and the second one is  s2=ff" .
The  i -th message is  si=si2+si1  afterwards. Let me give you some examples.
s3=cff" s4=ffcff"  and  s5=cffffcff" .

``I found the  i -th message's utterly charming," Jesus said.
``Look at the fifth message".  s5=cffffcff"  and two  cff"  appear in it.
The distance between the first  cff"  and the second one we said, is  5 .
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different  cff"  as substrings of the message.
 

Input
An integer  T (1T100) , indicating there are  T  test cases.
Following  T  lines, each line contain an integer  n (3n201314) , as the identifier of message.
 

Output
The output contains exactly  T  lines.
Each line contains an integer equaling to:
i<j:sn[i..i+2]=sn[j..j+2]=cff"(ji) mod 530600414,

where  sn  as a string corresponding to the  n -th message.
 

Sample Input
  
  
9 5 6 7 8 113 1205 199312 199401 201314
 

Sample Output
  
  
Case #1: 5 Case #2: 16 Case #3: 88 Case #4: 352 Case #5: 318505405 Case #6: 391786781 Case #7: 133875314 Case #8: 83347132 Case #9: 16520782
 

solution:

直接推公式即可,长度符合FIB序列,再统计一下c出现的位置和之前的答案

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll mod = 530600414;
const int maxn = 201320;
ll f[maxn],sum[maxn],ans[maxn],len[maxn];
int main()
{
    f[1] = 1; f[2] = 2; f[3] = 3;
    len[3] = 1; len[4] = 1;
    sum[3] = 1;
    for (int i = 4; i < maxn; i++)
    {
        f[i] = (f[i - 1] + f[i-2])%mod;
        len[i] = (len[i - 1] + len[i - 2])%mod;
        sum[i] = (sum[i - 2] + sum[i - 1]+(f[i-2]*len[i - 1])%mod)%mod;
        ans[i] = ans[i - 1] + ans[i - 2] + ((((f[i - 2] * len[i - 2])%mod - sum[i - 2]+mod)%mod)*len[i-1])%mod + (sum[i - 1] * len[i - 2])%mod;
        ans[i] %= mod;
    }
    int t,n;
    scanf("%d", &t);
    for (int i = 1; i <= t; i++)
    {
        scanf("%d", &n);
        printf("Case #%d: %I64d\n", i, ans[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值