贪心策略 CSU - 1065: Scientific Conference

题目:

Description

        Functioning of a scientific conference is usually divided into several simultaneous sections. For example, there may be a section on parallel computing, a section on visualization, a section on data compression, and so on.
       Obviously, simultaneous work of several sections is necessary in order to reduce the time for scientific program of the conference and to have more time for the banquet, tea-drinking, and informal discussions. However, it is possible that interesting reports are given simultaneously at different sections.
       A participant has written out the time-table of all the reports which are interesting for him. He asks you to determine the maximal number of reports he will be able to attend.

Input

        The first line contains the number 1 ≤ N ≤ 100000 of interesting reports. Each of the next N lines contains two integers Ts and Te separated with a space (1 ≤ Ts < Te ≤ 30000). These numbers are the times a corresponding report starts and ends. Time is measured in minutes from the beginning of the conference.

Output

        You should output the maximal number of reports which the participant can attend. The participant can attend no two reports simultaneously and any two reports he attends must be separated by at least one minute. For example, if a report ends at 15, the next report which can be attended must begin at 16 or later.

Sample Input

5
3 4
1 5
6 7
4 5
1 3

Sample Output

3

思路:

首先按照会议结束时间排序,如果当前会议的结束时间小于后面会议的开始时间,那么就安排这个会议,否则继续和下一个会议比较。

代码:

#include<iostream>
#include<algorithm>
using namespace std;

struct cl
{
	int start;
	int end;
};
bool cmp(cl a, cl b)
{
	if (a.end < b.end) return true;
	else return false;
}

cl cls[100000];
int main()
{
	int N; cin >> N;
	for (int i = 0; i < N; i++)
	{
		cin >> cls[i].start >> cls[i].end;
	}

	sort(cls, cls + N, cmp);

	int num = 1;
	int temp = 0;//这两个下标注意谁一定会遍历,谁会跳着遍历
	for (int i = 1; i < N; i++)
	{
		if (cls[i].start > cls[temp].end)
		{
			num++;
			temp = i;
		} 
	}
	cout << num;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值