贪心策略 HDU - 4864 Task

Description

Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars. 
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine. 
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.

Input

The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000). 
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine. 
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.

Output

For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.

Sample Input

1 2
100 3
100 2
100 1

Sample Output

1 50004

代码:

#include<iostream> 
#include<algorithm>
#include<string.h>
using namespace std;

//HDU - 4864
struct node{
	int xi;//时间 
	int yi;//难度 
	bool checked;//是否使用过 
};
bool cmpt(node a,node b){//Task以x为第一关键字降序排列,以y为第二关键字降序排列
	return (a.xi*500+a.yi*2)>(b.xi*500+b.yi*2);
}
bool cmpm(node a,node b){//Machine以y为第一关键字降序排列,以x为第二关键字降序排列 
	if(a.yi>b.yi) return true;
	if(a.yi<b.yi) return false;
	return a.xi>b.xi;
} 
node m[100000],t[100000];//m[]机器,t[]task 

int main(){
	int N,M;//N机器的数量,M的task的数量 
	//node m[100000],t[100000];栈溢出 
	while(cin>>N>>M){ 
		for(int i=0;i<N;i++){
			cin>>m[i].xi>>m[i].yi;
			m[i].checked=false;
		}
		sort(m,m+N,cmpm);
		for(int i=0;i<M;i++){
			cin>>t[i].xi>>t[i].yi;
			t[i].checked=false;
		}
		sort(t,t+M,cmpt);
		
		long long sum=0,num=0;//sum钱,num完成的任务数量  记住上限 
		int rank[101];//+各类y值对应的机器数 + 
		memset(rank, 0, sizeof(rank));
		
		for(int i=0;i<N;i++){//每一个y值有几个机器 
			rank[m[i].yi]++;
		} 
		for(int i=m[0].yi;i>0;i--){
			rank[i-1]=rank[i]+rank[i-1];//y值大于等于i-1对应的 机器有rank[i-1]个 
		}
		
		for(int i=0;i<M;i++){
			for(int j=rank[t[i].yi];j>0;j--){
				if((m[j-1].checked==false)&&t[i].xi<=m[j-1].xi&&t[i].yi<=m[j-1].yi){//==与= 
					sum=sum+t[i].xi*500+t[i].yi*2;
					num++;
					m[j-1].checked=true;
					break; //妈的   及时跳出 
				}
			}
		} 
		cout<<num<<" "<<sum<<endl;
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值