coj1065: Scientific Conference

Description

        Functioning of a scientific conference is usually divided into several simultaneous sections. For example, there may be a section on parallel computing, a section on visualization, a section on data compression, and so on.
       Obviously, simultaneous work of several sections is necessary in order to reduce the time for scientific program of the conference and to have more time for the banquet, tea-drinking, and informal discussions. However, it is possible that interesting reports are given simultaneously at different sections.
       A participant has written out the time-table of all the reports which are interesting for him. He asks you to determine the maximal number of reports he will be able to attend.

Input

        The first line contains the number 1 ≤ N ≤ 100000 of interesting reports. Each of the next N lines contains two integers Ts and Te separated with a space (1 ≤ Ts < Te ≤ 30000). These numbers are the times a corresponding report starts and ends. Time is measured in minutes from the beginning of the conference.

Output

        You should output the maximal number of reports which the participant can attend. The participant can attend no two reports simultaneously and any two reports he attends must be separated by at least one minute. For example, if a report ends at 15, the next report which can be attended must begin at 16 or later.

Sample Input

5
3 4
1 5
6 7
4 5
1 3

Sample Output

3
这道题比较郁闷,一开始用scanf总是超时,后来改成cin再关同步居然过了,一直都以为scanf比cin快,然后被狠狠打
脸,于是好好学习了cin和scanf的区别,这里推荐一篇大佬的博客
http://blog.sina.com.cn/s/blog_93294724010163rl.html
这道题主要是贪心,因为每个会议的结束时间都大于开始时间,所以以结束时间排序,然后for循环一个一个比对,如果
会议i的开始时间在会议i-1的结束时间之后,那么参加完会议i-1后可以继续参加会议i,此时将会议i的结束时间保存,答案
就出来了,挺水的贪心题
 
 
AC代码
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
  int sta;
  int end;
}con[100005];
bool cmp(node a,node b){
  if(a.end!=b.end)
  return a.end<b.end;
  else
  return a.sta<b.sta;
}
int main()
{
  ios::sync_with_stdio(false);
  int N;
  int cnt;
  int t;
  while(cin>>N)
  {
    cnt=1;
    for(int i=0;i<N;i++)
    {
      cin>>con[i].sta>>con[i].end;
    }
  sort(con,con+N,cmp);
  t=con[0].end;
  for(int i=1;i<N;i++)
    if(con[i].sta>t)
    {
      cnt++;
      t=con[i].end;
    }
  cout<<cnt<<endl;
  }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值