动态规划 HDU - 1003 Max Sum(最大子段和)

 
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
 
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
 
 
Case 1:14 1 4Case 2:7 1 6
思路:

构造b[j](也就是下面代码中的b)表示以a[j]为结尾的最大字段和的值。

代码:

#include<iostream>
//Max Sum HDU - 1003 

using namespace std;

int main() {
	int T;
	cin >> T;
	int casenum = 0;
	while (T--) {
		int N;
		cin >> N;

		int *a = new int[N];
		int sum = 0; int b = 0;// int low = 0; 
		int high = 0;
		for (int i = 0; i < N; i++) {//cin >> a[i];
			cin >> a[i];
			if (i == 0) {
				sum = b = a[i];
			}else {
				if (b > 0) {
					b += a[i];
				}else {
					b = a[i];
					//low = i;
				}
				if (sum < b) {
					sum = b;
					high = i; //求出最大值和结束为止
				}
			}	
		}

		//输出开始位置
		int sum1 = sum;
		int low=high;
		for (int i = high; i >=0; i--) {
			sum1 = sum1 - a[i];
			if (!sum1) {
				low = i;
				//break;
			}
		}

		delete []a;
		if (!T) {
			cout << "Case " << ++casenum << ":\n" << sum << " " << low + 1 << " " << high + 1 << endl;
		} else {
			cout << "Case " << ++casenum << ":\n" << sum << " " << low + 1 << " " << high + 1 << endl << endl;
		}
		
	}

	return 0;
}

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值