2016多校训练Contest10: 1001 Median hdu5857

题目链接http://acm.split.hdu.edu.cn/showproblem.php?pid=5857

Median

Problem Description

There is a sorted sequence A of length n. Give you m queries, each one contains four integers, l1, r1, l2, r2. You should use the elements A[l1], A[l1+1] … A[r1-1], A[r1] and A[l2], A[l2+1] … A[r2-1], A[r2] to form a new sequence, and you need to find the median of the new sequence.

Input

First line contains a integer T, means the number of test cases. Each case begin with two integers n, m, means the length of the sequence and the number of queries. Each query contains two lines, first two integers l1, r1, next line two integers l2, r2, l1<=r1 and l2<=r2.
T is about 200.
For 90% of the data, n, m <= 100
For 10% of the data, n, m <= 100000
A[i] fits signed 32-bits int.

Output

For each query, output one line, the median of the query sequence, the answer should be accurate to one decimal point.

Sample Input

1
4 2
1 2 3 4
1 2
2 4
1 1
2 2

Sample Output

2.0
1.5

题意

告诉你一个排好序的数组,给你两个区间,让你求出两个区间包含的所有元素的中间值(区间可以重复)

方法

分类讨论,两个区间重合和不重合的情况

代码

#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<cstdlib>
#include<iomanip>
#include<string>
#include<vector>
#include<map>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;
#define Max(a,b) (a>b)?a:b
#define lowbit(x) x&(-x)
int l1,l2,r1,r2,sum;
double a[100005];
double ans(int x)
{
    if(r1<=l2)
    {
        if(x<=r1-l1+1)
        {
            return a[l1+x-1];
        }
        else
        {
            return a[l2+x-1-r1+l1-1];
        }
    }
    else if(r1<=r2)
    {
        if(x<=l2-l1)
        {
            return a[l1+x-1];
        }
        else if(x>r1-l1+1+r1-l2+1)
        {
            return a[l2+x-r1+l1-1-1];
        }
        else
        {
            return a[l2+(x-l2+l1+1)/2-1];
        }
    }
    else
    {
        swap(r1,r2);
        if(x<=l2-l1)
        {
            return a[l1+x-1];
        }
        else if(x>r1-l1+1+r1-l2+1)
        {
            return a[l2+x-r1+l1-1-1];
        }
        else
        {
            return a[l2+(x-l2+l1+1)/2-1];
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%lf",&a[i]);
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d%d",&l1,&r1,&l2,&r2);
            if(l1>l2)
            {
                swap(l1,l2);
                swap(r1,r2);
            }
            sum=r1-l1+1+r2-l2+1;
            if(sum%2)
            {
                printf("%.1f\n",ans(sum/2+1));
            }
            else
            {
                printf("%.1f\n",(ans(sum/2)+ans(sum/2+1))/2);
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值