解题报告:POJ_1338 Ugly Numbers

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10


思路:一个数一个数的判断超时妥妥的,所以这里要用一定的技巧。+我们知道,第一个数是1,那么第二个数就是1*2,1*3,1*5的最小值2,这时第一个数的二的倍数就用过了,第三个数就是第二个数的2的倍数,第一个数的3的倍数,第一个数的5的倍数这三个数中的最小值。。。。。。依次类推,可能表述得不是很清楚,详见代码。



/**
一个数一个数的判断严重超时。
考虑另一种做法:
定义3个记录下标的变量:a,b,c分别用来计算2的倍数,3的倍数,5的倍数。
每次取最小且不重复数放入数组中并把相等倍数值的下标后移(即进行处理下一个数2/3/5倍)
手动模拟前10个数可以帮助很好的理解。
**/
#include<cstdio>
#include<algorithm>
using namespace std;

int A[1500+5];
int main()
{
    A[0]=1;
    int a=0,b=0,c=0,tem;
    for(int n=1;n<1500;n++)
    {
        tem=A[a]*2;
        tem=min(tem,A[b]*3);
        tem=min(tem,A[c]*5);
        A[n]=tem;
        if(A[n]==A[a]*2)
            a++;
        if(A[n]==A[b]*3)
            b++;
        if(A[n]==A[c]*5)
            c++;
    }
    int t;
    while(scanf("%d",&t)&&t)
    {
        printf("%d\n",A[t-1]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值