HDU 1532 Drainage Ditches(网络流水题【Edmond-Karp算法】)

22 篇文章 0 订阅
7 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1532
Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15680 Accepted Submission(s): 7474

Problem Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output
50

【思路分析】本题是一道典型的网络流题目,也是我学网络流做的第一道题。
网络流的第一种算法:Edmond-karp算法。
所有的解释都在代码中。
【AC代码】

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
#define INT_MAX 0x3fffffff
const int MAXN=210;
int map[MAXN][MAXN],n,p[MAXN];//map:邻接数组;n:点数;p:前驱数组;
bool EK_bfs(int start,int end)//广度优先算法寻找增光路
{
    queue<int>que;//广度优先搜索队列
    bool flag[MAXN];//标记数组
    memset(flag,false,sizeof(flag));
    memset(p,-1,sizeof(p));//初始化
    que.push(start);
    flag[start]=true;
    while(!que.empty())
    {
        int e=que.front();
        if(e==end)
        {
            return true;
        }
        que.pop();
        for(int i=1;i<=n;i++)
        {
            if(map[e][i]&&!flag[i])
            {
                flag[i]=true;
                p[i]=e;
                que.push(i);
            }
        }
    }
    return false;
}

int EK_Max_Flow(int start,int end)
{
    int u,flow_ans=0,mn;
    while(EK_bfs(start,end))//假如能找到增广路,让水流从这条路上经过
    {
        mn=INT_MAX;
        u=end;
        while(p[u]!=-1)
        {
            mn=min(mn,map[p[u]][u]);
            u=p[u];
        }
        flow_ans+=mn;//总水流量增加
        u=end;
        while(p[u]!=-1)//增光路上的每一条边的可通过量减少
        {
            map[p[u]][u]-=mn;
            map[u][p[u]]+=mn;
            u=p[u];
        }
    }
    return flow_ans;
}

int main()
{
    int m;
    while(~scanf("%d%d",&m,&n))
    {
        memset(map,0,sizeof(map));
        int u,v,cost;
        for(int i=0;i<m;i++)//本题中会有重边
        {
            scanf("%d%d%d",&u,&v,&cost);
            map[u][v]+=cost;
        }
        int ans=EK_Max_Flow(1,n);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值