HDU 3549 Flow Problem(网络流水题【Edmond-Karp算法】)

22 篇文章 0 订阅
7 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3549

Flow Problem

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 13768 Accepted Submission(s): 6569

Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output
For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output
Case 1: 1
Case 2: 2

Author
HyperHexagon

【题目分析】简单的网络流题目,直接套上模板就搞定了。
【AC代码】

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
#define INT_MAX 0x3fffffff
const int MAXN=210;
int map[MAXN][MAXN],n,p[MAXN];//map:邻接数组;n:点数;p:前驱数组;
bool EK_bfs(int start,int end)//广度优先算法寻找增光路
{
    queue<int>que;//广度优先搜索队列
    bool flag[MAXN];//标记数组
    memset(flag,false,sizeof(flag));
    memset(p,-1,sizeof(p));//初始化
    que.push(start);
    flag[start]=true;
    while(!que.empty())
    {
        int e=que.front();
        if(e==end)
        {
            return true;
        }
        que.pop();
        for(int i=1;i<=n;i++)
        {
            if(map[e][i]&&!flag[i])
            {
                flag[i]=true;
                p[i]=e;
                que.push(i);
            }
        }
    }
    return false;
}

int EK_Max_Flow(int start,int end)
{
    int u,flow_ans=0,mn;
    while(EK_bfs(start,end))//假如能找到增广路,让水流从这条路上经过
    {
        mn=INT_MAX;
        u=end;
        while(p[u]!=-1)
        {
            mn=min(mn,map[p[u]][u]);
            u=p[u];
        }
        flow_ans+=mn;//总水流量增加
        u=end;
        while(p[u]!=-1)//增光路上的每一条边的可通过量减少
        {
            map[p[u]][u]-=mn;
            map[u][p[u]]+=mn;
            u=p[u];
        }
    }
    return flow_ans;
}

int main()
{
    int m,t,iCase=0;
    scanf("%d",&t);
    while(t--)
    {
        printf("Case %d: ",++iCase);
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        int u,v,cost;
        for(int i=0;i<m;i++)//本题中会有重边
        {
            scanf("%d%d%d",&u,&v,&cost);
            map[u][v]+=cost;
        }
        int ans=EK_Max_Flow(1,n);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值