POJ 3264 Balanced Lineup(RMQ查找区间最值)

36 篇文章 0 订阅
1 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3264

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 49179 Accepted: 23031
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output

6
3
0
Source

USACO 2007 January Silver

【中文题意】给出n和m,代表有n个数的序列,然后有m次询问,每次询问给出a和b,让你求出这个区间内的最大值减去最小值是多少。
【思路分析】RMQ裸题,直接套上板子就干了,当然也可以用线段树来做,查询区间的最大值和最小值。
【AC代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN=50010;
int dp[MAXN][20],dp2[MAXN][20];
int mm[MAXN];
int a[MAXN];

void initRMQ(int n)
{
    mm[0]=-1;
    for(int i=1;i<=n;i++)
    {
        mm[i]=((i&(i-1))==0)?mm[i-1]+1:mm[i-1];
        dp[i][0]=a[i];
        dp2[i][0]=a[i];
    }
    for(int j=1;j<=mm[n];j++)
    {
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
            dp2[i][j]=min(dp2[i][j-1],dp2[i+(1<<(j-1))][j-1]);
        }
    }
}

int rmqMAX(int x,int y)
{
    int k=mm[y-x+1];
    return max(dp[x][k],dp[y-(1<<k)+1][k]);
}

int rmqMIN(int x,int y)
{
    int k=mm[y-x+1];
    return min(dp2[x][k],dp2[y-(1<<k)+1][k]);
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        initRMQ(n);
        int u,v;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            if(u>v)
            {
                int temp=u;
                u=v;
                v=temp;
            }
            printf("%d\n",rmqMAX(u,v)-rmqMIN(u,v));
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值