1079. Total Sales of Supply Chain (25)<BFS,DFS,并查集>

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4
广搜,注意存储的长度,要建立pair,就像Dijkstra一样。长度对应增加

由于这题的特殊性,不需要判断是否遍历过。(不存在回路)

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
using namespace std;
int value[100001];
vector<int> v[100001];
typedef pair<int,int> P;
double sum=0;
int n;
double p,r;
double rata;
void f(int x){
	queue<P> que;
	que.push({x,0});
	while(que.size()){
		P pp=que.front();
		que.pop();
		int num=pp.first;
		int len=pp.second;
		if(v[num].size()==0){
			sum+=p*value[num]*pow(rata,len);
		}
		else{
			for(int i=0;i<v[num].size();i++){
				que.push({v[num][i],len+1});
			}
		}
	}
}
int main(){
	
	cin>>n>>p>>r;
	rata=1+1.0*(r)/100;
	
	for(int i=0;i<n;i++){
		int num;
		scanf("%d",&num);
		if(num==0){
			int fz;
			scanf("%d",&fz);
			value[i]=fz;
		}
		else{
			for(int j=0;j<num;j++){
				int fz;
				scanf("%d",&fz);
				v[i].push_back(fz);
			}
		}	
	}
	f(0);
	printf("%.1f",sum);
	return 0;
}

深搜:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
using namespace std;
int value[100001];
vector<int> v[100001];
typedef pair<int,int> P;
double sum=0;
int n;
double p,r;
double rata;
void f(int x,int len){
	if(v[x].size()==0){
		sum+=p*value[x]*pow(rata,len);
	}
	else{
		for(int i=0;i<v[x].size();i++){
			f(v[x][i],len+1);
		}
	}
}
int main(){
	
	cin>>n>>p>>r;
	rata=1+1.0*(r)/100;
	
	for(int i=0;i<n;i++){
		int num;
		scanf("%d",&num);
		if(num==0){
			int fz;
			scanf("%d",&fz);
			value[i]=fz;
		}
		else{
			for(int j=0;j<num;j++){
				int fz;
				scanf("%d",&fz);
				v[i].push_back(fz);
			}
		}	
	}
	f(0,0);
	printf("%.1f",sum);
	return 0;
}

并查集: 超时一个点,没想到啥简化的方法

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
using namespace std;
int value[100001];
vector<int> v[100001];
typedef pair<int,int> P;
double sum=0;
int n;
double p,r;
double rata;
void f(int x,int len){
	if(v[x].size()==0){
		sum+=p*value[x]*pow(rata,len);
	}
	else{
		for(int i=0;i<v[x].size();i++){
			f(v[x][i],len+1);
		}
	}
}
int main(){
	
	cin>>n>>p>>r;
	rata=1+1.0*(r)/100;
	
	for(int i=0;i<n;i++){
		int num;
		scanf("%d",&num);
		if(num==0){
			int fz;
			scanf("%d",&fz);
			value[i]=fz;
		}
		else{
			for(int j=0;j<num;j++){
				int fz;
				scanf("%d",&fz);
				v[i].push_back(fz);
			}
		}	
	}
	f(0,0);
	printf("%.1f",sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值