PAT 甲级 1079 Total Sales of Supply Chain(25 分)

1079 Total Sales of Supply Chain(25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4
# include <iostream>
# include <vector>
# include <algorithm>
# include <cmath>
using namespace std;
const int maxn = 1e5 + 50;

int n;
double p, r, sum = 0;
int num[maxn];
double price[maxn];
vector<int> sup[maxn];

void DFS(int st, int depth){
	if(sup[st].size() == 0){
		price[st] = pow((1 + r/ 100), depth-1) * p * num[st];
//		cout << price[st] << ' ' << pow((1 + r), depth-1) << ' ' << st << ' ' << num[st] << ' ' << depth << endl;
		return ;
	}
	for(int i = 0; i < sup[st].size(); i++){
		DFS(sup[st][i], depth + 1);
	}
}


int main(){
//	freopen("C:\\1.txt", "r", stdin);
	fill(num, num + maxn, 0);
	fill(price, price + maxn, 0.0);
	scanf("%d %lf %lf", &n, &p, &r);
	for(int i = 0; i < n; i++){
		int a, b;
		scanf("%d", &a);
		if(a != 0){
			for(int j = 0; j < a; j++){
				scanf("%d", &b);
				sup[i].push_back(b);
			}
		}
		else{
			scanf("%d", &b);
			num[i] = b;
		}
	}
	DFS(0, 1);
	for(int i = 0; i < n; i++){
		sum += price[i];
	}
	printf("%.1lf\n", sum);
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值