【PAT刷题甲级】1079.Total Sales of Supply Chain

1079 Total Sales of Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10 ^5 ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10 ^10 .

Sample Input

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output

42.4

题意

销售链:供应商——经销商——零售商,计算零售商的销售总额。
从供应商出进货价格为P,经销商分发或者零售商出售都要在进价的基础上再加r%的价格。
可抽象为一棵树,供应商为根节点,零售商为叶子节点,经销商为普通节点。利用层序遍历。设零售商进货数量为data,叶子结点的层数为layer,每个零售商的销售总额P*(1+r%)^(layer-1)*data,所有叶子结点计算的销售额相加即可得到最终结果。
注意:不超过10^10应该用double型。

代码

#include <iostream>
#include <vector>
#include <queue>
#include <cmath>	//使用pow函数 
using namespace std;
int n,m;
double p,r,sum;
struct node {
	double data,layer;
	vector<int> child;
} Node[100001];
void layOrder(int root) {	//层序遍历 
	queue<int> q;
	q.push(root);
	Node[root].layer=0;
	while(!q.empty()) {
		int now=q.front();
		sum += Node[now].data * p * pow(1+r*0.01,Node[now].layer);
		q.pop();
		for(int i=0; i<Node[now].child.size(); i++) {
			int child=Node[now].child[i];
			Node[child].layer=Node[now].layer+1;
			q.push(child);
		}
	}
}
int main() {
	scanf("%d%lf%lf",&n,&p,&r);
	for(int i=0; i<n; i++) {
		scanf("%d",&m);
		Node[i].child.resize(m);
		if(m!=0) {
			for(int j=0; j<m; j++) {
				scanf("%d",&Node[i].child[j]);
			}
		} else {
			scanf("%lf",&Node[i].data);
		}
	}
	layOrder(0);
	printf("%.1lf",sum);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值