第八道ACM程序题

1.题目编号:1017

原题:

Problem Description


A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.


 


Input


The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.



Output


The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.


 


Sample Input


  
  
0 0 4 0 0 1 7 5 1 0 0 0 0 0 0 0 0 0


 


Sample Output


  
  
2 1


 2.简单题意:一个厂商生产的产品为同一高度h和大小为1*1,2*2,3*3,4*4,5*5,6*6,最后交付到客户手里都是6*6的包裹,根据客户需要的产品,用最少的包裹去包装,以此来节省开支
3.解题思路形成过程:看到这个问题首先想到的还是贪心算法,如何让包裹最少,就需要让每个包裹都塞满,其中6*6,5*5,4*4的产品每个都需要一个箱子,5*5和11个1*1放在一起;4*4和11个2*2的放在一起;3*3可以恰好装满,3*3的可以和5个2*2和7个1*1放一起,3*3可以和3个2*2和6个1*1,3*3可以和1个2*2、5个1*1在一起;多余的2*2可以和1*1放一起,若2*2 不够的话就用1*1来补。这样搞清楚思路就可以写代码了
4.感悟:这个题的代码很简单,但是想起来并不是那么容易,你需要每种情况都考虑到,在写代码的过程中需要用到数学知识,要知道怎样用数学算式表示向上取整。在while循环的时候出现了一些错误,查找了一下资料才明白用sum=0的条件语句就可以使都取0时结束程序,想法真的很重要!
5AC的代码:
#include<iostream>
using namespace std;
int main(){
    int a,b,c,d,e,f;
    int n[4]={0,5,3,1};
    while(cin>>a>>b>>c>>d>>e>>f&&(a+b+c+d+e+f)!=0){
        int count=0;
        int sum=0;
        int bl,al;
        sum=f+e+d+(c+3)/4;
         bl=n[c%4]+d*5;
         if (bl<b){
             sum=sum+(b-bl+8)/9;
         }
         al=sum*36-b*4-c*9-d*16-e*25-f*36;
         if (al<a){
              sum=sum+(a-al+35)/36;
         }
         cout<<sum<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值