1016. Phone Bills (25)

该问题涉及模拟电话费用计算,根据一天24小时内不同的费率计算每分钟费用。输入包含费率表和通话记录,输出是按字母顺序排列的客户账单,详细列出每次通话的开始和结束时间、持续时间及费用,最后给出每月总费用。
摘要由CSDN通过智能技术生成

大模拟+排序
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 12.10
CYLL 01
01:06:01 01:08:03 122 3.85
Total amount: 638.80
Total amount: $638.80

Pat上的Java太坑了,C/C++写pat比较好

参考了思路
http://blog.csdn.net/sunbaigui/article/details/8657062

Java实现:

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
public class Main {
  static int[] charge = new int[25];
  static class Cnode {
    String name;
    int month;
    int date;
    int hours;
    int minutes;
    int total;
    String status;
    public Cnode(String name, int month, int date, int hours, int minutes, int total, String status) {
      this.name = name;
      this.month = month;
      this.date = date;
      this.hours = hours;
      this.minutes = minutes;
      this.total = total;
      this.status = status;
    }

  }
  public static void main(String[] args) {
    try {
      //input
      BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
      String caString = bufferedReader.readLine();
      for (int i = 0; i < 24; i++) {
        charge[i] = Integer.parseInt(caString.split(" ")[i]);
      }
      int n = Integer.parseInt(bufferedReader.readLine());
      ArrayList<Cnode> list = new ArrayList<>();
      ArrayList<Cnode> format_list = new ArrayList<>();
      for (int i = 0; i < n; i++) {
        caString = bufferedReader.readLine();
        String name = caString.split(" ")[0];
        int month = Integer.parseInt(caString.split(" ")[1].split(":")[0]); 
        int date = Integer.parseInt(caString.split(" ")[1].split(":")[1]);
        int hours = Integer.parseInt(caString.split(" ")[1].split(":")[2]); 
        int minutes = Integer.parseInt(caString.split(" ")[1].split(":")[3]);  
        String status = caString.split(" ")[2];
        Cnode cnode = new Cnode(
            name,
            month,
            date,
            hours,
            minutes,
            minutes + 60*hours + 24*60*date, 
            status 
            );
        list.add(cnode);
      }
      Collections.sort(list, new cmp());  
//      //filter bad record
      boolean haveonline = false;
      String curname = "";

      for (int i = 0; i < list.size(); i++) {
        if (haveonline == false && list.get(i).status.equals("on-line")) {
          format_list.add(list.get(i));
          haveonline = true;
          curname = list.get(i).name;
        } else if (haveonline == true && list.get(i).status.equals("on-line")) {
          format_list.remove(format_list.size()-1);
          format_list.add(list.get(i));
          haveonline = true;
          curname = list.get(i).name;
        } else if (haveonline == true && list.get(i).status.equals("off-line") && list.get(i).name.equals(curname)) {
          format_list.add(list.get(i));
          haveonline = false;
        }
      }
      if (format_list.get(format_list.size()-1).status.equals("on-line")) format_list.remove(format_list.size()-1);
      //output
      double totalcost = 0.0;
      curname = "";
      for (int i = 0; i < format_list.size(); i += 2) {
        Cnode cal1 = format_list.get(i);
        Cnode cal2 = format_list.get(i+1);
        if (!cal1.name.equals(curname)) {
          if (!curname.equals("")) {
            System.out.printf("Total amount: $%.2f\n", totalcost);
            totalcost = 0;
            System.out.printf("%s %02d\n", cal1.name, cal1.month);
          } else {
            System.out.printf("%s %02d\n", cal1.name, cal1.month);
          }
          curname = cal1.name;
        }
        System.out.printf("%02d:%02d:%02d", cal1.date, cal1.hours, cal1.minutes);
        System.out.printf(" %02d:%02d:%02d", cal2.date, cal2.hours, cal2.minutes);


        int totallast = (cal2.date-cal1.date)*24*60+(cal2.hours-cal1.hours)*60+(cal2.minutes-cal1.minutes);
        System.out.printf(" %d", totallast);
        System.out.printf(" $%.2f\n", calCost(cal1, cal2));
        totalcost += calCost(cal1, cal2);
      }
      System.out.printf("Total amount: $%.2f\n", totalcost);

    } catch (Exception e) {
      e.printStackTrace();
    }
  }
  static class cmp implements Comparator<Cnode> {
    @Override
    public int compare(Cnode o1, Cnode o2) {
      if (o1.name.compareTo(o2.name) < 0) return -1;
      else if (o1.name.equals(o2.name) && o1.total < o2.total) return -1;
      else return 1;
    }
  }  
  static double calCost(Cnode c1, Cnode c2) {
    return (double)(chargeByTime(c2.total)-chargeByTime(c1.total))/100;
  }
  static int chargeByTime(int time) {
    int hours = time/60;
    int minutes = time%60;
    int money = 0;
    int i = 0;
    for (i = 0; i < hours; i++) {
      money += charge[i%24]*60;
    }
    money += charge[i%24]*minutes;
    return money;
  }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值