1016 Phone Bills (25 分)

1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目大意:
给定一组通话信息,要求按字典序输出每一个用户的通话时间和话费

算法分析
将记录先按id排序,再按通话时间排序。前后两个id相同,且前一个为on-line,后一个为off-line的即为有效数据

代码(15分,只过了第一个点)

#include<bits/stdc++.h>
using namespace std;
struct node{
	string id;
	int month,day,hour,minute,flag;
};
int fee[25],num;
double billfromzero(node n){
	double sum=0;
	sum+=fee[n.hour]*n.minute+n.day*fee[24]*60;
	for(int i=0;i<n.hour;i++)
	sum+=fee[i]*60;
	sum*=0.01;
	return sum;
}
int timefromzero(node n){
	int sum=0;
	sum=n.day*24*60+n.minute;
	for(int i=0;i<n.hour;i++)
	sum+=60;
	
	return sum;
}
int cmp(node a,node b){
	if(a.id!=b.id)return a.id<b.id;
	else
	return timefromzero(a)<timefromzero(b); 
}//从00:00:00开始算 
int main()
{
	for(int i=0;i<24;i++){
		cin>>fee[i];
		fee[24]+=fee[i];
	} 
	scanf("%d",&num);
	node cus[num];
	string temp;
	for(int i=0;i<num;i++){
		getchar();
		cin>>cus[i].id;
		scanf("%d:%d:%d:%d",&cus[i].month,&cus[i].day,&cus[i].hour,&cus[i].minute);
		cin>>temp;
		if(temp=="on-line")
		cus[i].flag=1;
		else
		cus[i].flag=-1;
	}
	sort(cus,cus+num,cmp);
	vector<node> v;
	for(int i=0;i<num-1;i++){//注意i<num-1,防止越界 
		if(cus[i].flag=1&&cus[i+1].flag==-1&&cus[i].id==cus[i+1].id){
			v.push_back(cus[i]);
			v.push_back(cus[i+1]);
		}
	}
	string front="1111111111111111111111111111111111111";
	double sum=0;
	for(int i=0;i<v.size();i+=2){
		if(v[i].id!=front){//id与前面不同的,需要多输出一行 
			cout<<v[i].id;
			printf(" %02d\n",v[i].month);
			sum=billfromzero(v[i+1])-billfromzero(v[i]);
		}
		else
		sum+=billfromzero(v[i+1])-billfromzero(v[i]);
		int time=timefromzero(v[i+1])-timefromzero(v[i]);
		printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2lf\n",v[i].day,v[i].hour,v[i].
		minute,v[i+1].day,v[i+1].hour,v[i+1].minute,time,billfromzero(v[i+1])-billfromzero(v[i]));
		if(i==v.size()-2||v[i+1].id!=v[i+2].id)//id与后面不同的,需要多输出一行 
		//注意i==v.size()-2这个条件一定要放前面,不然i取到比较大的值时后面会越界 
		printf("Total amount: $%.2lf\n",sum);
		front=v[i].id;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值