1016 Phone Bills (25 分)(C++)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

解题思路:

首先关于存储,map映射,每个名字映射一个序号,将同序号的存放到一起,方便计算;

其次关于有效记录:1095那道题也有类似的这种一进一出,其中可能有无效的,我用flag标记该记录是on,还是off,可能出现的几种情况,

上一次0 ,本次也是0:上次的无效,直接修改lastindex

上一个1,本次也是1:本次无效,直接访问下一个

上一个1,本次0:修改lastindex和lastflag

上一个0,本次1:需要计算价钱和时间

最后计算价钱以及时间:对每个记录在保存的时候就直接记录从该月的01:00:00开始到电话的话,到现在时间为多久,价格为多少,这样最后计算任意两个记录之间的时间和价格就只需要相减即可。

#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <algorithm>
using namespace std;
typedef struct 
{
	int month, day, hour, minu, flag, time;
	double p;
}record;
std::vector<record> records[1005];
int n, cnt = 0;
double price[24], one_day_price = 0;
map<string, int>mp;
map<int, string>mp2;
void getprice_time(record &x){
	x.p = one_day_price * (x.day - 1);
	x.time = 1440* (x.day - 1);
	for(int i = 0; i < x.hour; ++ i)
		x.p += price[i];
	x.time += x.hour * 60;
	x.p += (price[x.hour] / 60) * x.minu;
	x.time += x.minu;
}
int main(){
	for(int i = 0; i < 24; ++ i){
		scanf("%lf", &price[i]);
		price[i] *= 0.6;
		one_day_price += price[i];
	}
	scanf("%d", &n);
	for(int i = 0; i < n; ++ i){
		string name, tempflag;
		record temprecord;
		cin >> name;
		scanf("%d:%d:%d:%d",&temprecord.month, &temprecord.day, &temprecord.hour, &temprecord.minu);
		cin >> tempflag;
		temprecord.flag = (tempflag[1] == 'n' ? 0 : 1);
		getprice_time(temprecord);
		if(mp.find(name) == mp.end()){
			mp[name] = cnt;
			mp2[cnt ++] = name;
		}
		records[mp[name]].push_back(temprecord);
	}
	std::vector<int> rank(cnt);
	for(int i = 0; i < cnt; ++ i)
		rank[i] = i;
	sort(rank.begin(), rank.end(),[](int a, int b){return mp2[a] < mp2[b];});
	for(int i = 0; i < cnt; ++ i){
		int id = rank[i];
		sort(records[id].begin(), records[id].end(), [](record a, record b){return a.time < b.time;});
		double sum = 0.0;
		int lastflag = 1, lastindex = 0;
		for(int j = 0; j < records[id].size(); ++ j){
			if(lastflag == 1 && records[id][j].flag == 0){
				lastindex = j;
				lastflag = 0;
			}
			else if(lastflag == 0 && records[id][j].flag == 1){
				double tempp = (records[id][j].p - records[id][lastindex].p);
				int temptime = (records[id][j].time - records[id][lastindex].time);
				if(sum == 0)
					printf("%s %02d\n", mp2[id].c_str(), records[id][j].month);
				printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", records[id][lastindex].day, records[id][lastindex].hour, records[id][lastindex].minu, records[id][j].day, records[id][j].hour, records[id][j].minu, temptime, tempp);
				sum += tempp;
				lastflag = 1;
				lastindex = j;
			}
			else if(lastflag == 0)
				lastindex = j;
		}
		if(sum != 0)
			printf("Total amount: $%.2f\n", sum);
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值