HDU 2608 0 or 1 【找规律】

题目传送门:点击打开链接

0 or 1

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3837    Accepted Submission(s): 1095


Problem Description
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).
 

Input
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.
 

Output
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .
 

Sample Input
 
 
3 1 2 3
 

Sample Output
 
 
1 0 0
Hint
Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8 S(3) % 2 = 0
 

Author
yifenfei
 

Source
 

T(n)是所有能够被n整除的数的和


对于这题,我们可以先打个表。找一下规律。

#include<iostream>
#include<cstdio>
#define N 200
int T[N],S[N];
int main()
{
    int t,n,i;
    for(n=1; n<N; n++)
    {
        for(i=1; i<=n; i++)
        {
            if(n%i==0)
            {
                T[n] += i;
            }
        }
        S[n] = S[n-1]+T[n];

        printf("n=%d,T[n]=%d,S[n]=%d\n",n,T[n],S[n]);
    }
}

打表的结果


我们可以得出结论,当n为完全平方数或者是完全平方数的两倍时,T[n]便为奇数

如果S【n】中有奇数个   奇数T[n]  那么S【n】便为奇数,反之便为偶数。

那么这题就转换为:找T【1】~T【n】中有几个奇数

也就转换为

找1~n中有几个完全平方数,和有几个是完全平方数二倍的数


1~n中完全平方数的个数为  sqrt(n)(取整)

1~n中是完全平方数二倍的数的个数为   sqrt(n/2)(取整)


那么这题的代码就很简单了


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        scanf("%d",&n);

        int sum1=(int)sqrt(n*1.0);///计算完全平方数
        int sum2=(int)sqrt((n*1.0)/2.0);///计算完全平方数的二倍的个数

        printf("%d\n",(sum1+sum2)%2);

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值