hdu - 2608 -0 or 1(规律)

0 or 1

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 986    Accepted Submission(s): 204


Problem Description
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n). 
 

Input
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.
 

Output
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .
 

Sample Input
      
      
3 1 2 3
 

Sample Output
      
      
1 0 0
Hint
Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8 S(3) % 2 = 0


题目不多解释了。

打表前50个元素如下

10011110111111100111111100000001111000000000000010.....

经过打表之后,发现转折点(0->1或者1->0)

有如下规律

1 1 平方根为:1
2 0
4 1 平方根为:2
8 0
9 1 平方根为:3
16 0 平方根为:4
18 1
25 0 平方根为:5
32 1
36 0 平方根为:6
49 1 平方根为:7
50 0
64 1 平方根为:8
72 0
81 1 平方根为:9
98 0
100 1 平方根为:10
121 0 平方根为:11
128 1
144 0 平方根为:12
162 1

其他非平方数的数均是由2与一个平方数相乘得到,如18=2*9,50=2*25,98=2*49


于是乎打表。把所有转折点打出来。

再现行查看给的n属于哪个范围即可!


CODE:

#include <iostream>
#include <algorithm>
using namespace std;
const __int64 inf=1<<31;
__int64 num[100000];
int main()
{
	__int64 i,j;
	num[0]=0;
	for(i=1;i<=46368;i++)
		num[i]=i*i;
	int cnt=i;
	for(i=0;i<=46368;i++)
		num[cnt++]=num[i]<<1;

	sort(num,num+cnt);
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=2;i<cnt;i++)
		{
			if(n>=num[i]&&n<num[i+1])
			{
				printf("%d\n",(i+1)&1);
				break;
			}
		}
	}
	return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值