ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 A Saving Tang Monk II【分层bfs】

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

'S' : The original position of Sun Wukong

'T' : The location of Tang Monk

'.' : An empty room

'#' : A deadly gas room.

'B' : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a 'B' room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

'P' : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a 'P' room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn't get into a '#' room(deadly gas room) without an oxygen bottle. Entering a '#' room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a '#' room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print -1

样例输入

2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0

样例输出

-1
8
11

 

题意:孙悟空在S点,唐僧在T点。孙悟空要去救唐僧。一路上有很多房间, ' . '代表的是普通房间,B代表的是有氧气瓶的房间,P代表的是有加速药的房间,#代表毒气室。孙悟空在没有氧气瓶的情况下不能进入毒气室,在有氧气瓶的情况下,进入毒气室后需要休息一个单位时间。孙悟空最多携带五个氧气瓶,但是可以携带无数个加速药丸。加速药丸可以使下一次移动不费时间(相当于进入P房间无需时间)。

 

问最需要多少时间可以救出唐僧,如果不行,输出-1;

 

 

采用分层bfs, 把氧气瓶数量看成一个特征量。这样相当于一个三维移动点(x,y,b) b是氧气瓶数量。

因为加速药丸可以无限携带,所以不作为特征量。

 

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 1e2 +5;
const int INF = 0x3f3f3f3f;
int X[4] = {0,0,-1,1};
int Y[4] = {1,-1,0,0};
char str[MAXN][MAXN];
int  vis[10][MAXN][MAXN];
int n,m,sx,sy;
struct Node
{
    int x,y,t,b;///t是时间,b是氧气瓶数目
    bool operator<(const Node &a)const///优先队列返回所用时间少的那一个
    {
        return t>a.t;
    }
};
priority_queue<Node>q;
void init()
{
    M(vis,0);
    while(!q.empty())q.pop();
}
int bfs(int x,int y)
{
    q.push({x,y,0,0});
    while(!q.empty())
    {
        int x1 = q.top().x;
        int y1 = q.top().y;
        int t1 = q.top().t;
        int b1 = q.top().b;
        q.pop();

        if(vis[b1][x1][y1]==0)
            vis[b1][x1][y1] =1;
        else
            continue;


        for(int i=0; i<4; i++)
        {
            int xx = x1 +X[i];
            int yy = y1 +Y[i];
            if(xx>=1&&xx<=n&&yy>=1&&yy<=m)
            {
                if(str[xx][yy] =='T')
                {
                    return t1+1;
                }
                else if(str[xx][yy] == '.'||str[xx][yy] == 'S')///普通房间,时间+1
                {
                    q.push({xx,yy,t1+1,b1});
                }
                else if(str[xx][yy] == '#' && b1>0)///有氧气瓶的情况下进入毒气室,时间+2,氧气瓶数-1
                {
                    q.push({xx,yy,t1+2,b1-1});
                }
                else if(str[xx][yy] == 'B')///进入氧气瓶室,氧气瓶数+1,但不大于5。
                {
                    q.push({xx,yy,t1+1,min(5,b1+1)});
                }
                else if(str[xx][yy] == 'P')///进入加速药丸室,不花费时间。
                {
                    q.push({xx,yy,t1,b1});
                }
            }
        }

    }
    return -1;
}
int main()
{
    while(scanf("%d %d",&n,&m)&&n&&m)
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%s",str[i]+1);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(str[i][j]=='S' )///确定起点
                {
                    sx = i;
                    sy = j;
                }
            }
        }
        int ans = bfs(sx,sy);
        printf("%d\n",ans);
    }
    return  0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值