POJ-3061 Subsequence

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

大致题意就是说找出一段最短的连续数字之和大于s,这个题可以用尺取法,先找到符合条件的情况,即从第一个数开始往右遍历,当第一次大于s的时候停下,在这里我们可以分析一下,如果在大于s的情况下继续累加增加长度并没什么意义,所以我们可以考虑修剪左端的数字,看是否还满足大于s,随机找出最小的满足情况的长度,反复操作即可找到最优结果

#include<iostream>
using namespace std;
int main()
{
	int t,n,s;
	cin>>t;
	while(t--)
	{
		cin>>n>>s;
		int a[100005];
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		int sum=0,i=0,len=n+1,t=0; //sum记录当前总和,i记录当前片段的最右端,t即左端,len存储更新的最优长度
		while(i<=n)
		{
			if(sum<s)
			{
				sum+=a[i++];
			}
			while(sum>=s){
				len=min(len,i-t);
				sum-=a[t++];
			}
		}
		 cout<<len%(n+1)<<endl;
	}
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值