There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
5
思路:做这一题时知道:一棵树,每个节点都有一个值,要选出一些点使得这些值最大,要求父亲和孩子节点不能同时选,只能出现一个这一个思路写下去,但是没有想到用dp写。
看了别了的博客及思路如下。
当前节点为i,dp[i][0]为i不出席时的最大快乐值,dp[i][1]为i出席时的最大快乐值。i的儿子集合(直接下属集合)为son={s1,s2,···},则有
(1)求解dp[i][0]:
for each si in son
dp[i][0] += max(dp[si][0], dp[si][1]);
解释:i不出席时,i的儿子既可以出席也可以不出席,取快乐值最大的方案。
(2)求解dp[i][1]:
for each si in son
dp[i][1] += dp[si][0];
解释:i出席,则i的所有儿子只能不出席。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int maxn = 6002;
struct maxVal
{
int x,y;
} dp[maxn];
vector<int> G[maxn];
bool isroot[maxn];
maxVal dfs(int v)
{
if(G[v].empty())
{
return dp[v];
}
for(int i = 0; i < G[v].size(); i++)
{
maxVal val = dfs(G[v][i]);
dp[v].x += max(val.x,val.y);
dp[v].y += val.x;
}
return dp[v];
}
int main()
{
int n,root;
while(scanf("%d",&n) != EOF)
{
for(int i = 1; i <= n; i++)
{
scanf("%d",&dp[i].y);
dp[i].x = 0;
isroot[i] = true;
G[i].clear();
}
int l,k;
while(scanf("%d%d",&l,&k) && l)
{
G[k].push_back(l);
isroot[l] = false;
}
for(int i = 1; i <= n; i++)
{
if(isroot[i])
{
root = i;
break;
}
}
maxVal ans = dfs(root);
printf("%d\n",max(ans.x,ans.y));
}
return 0;
}