The Perfect Stall POJ - 1274

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 
Sample Output
4


匈牙利算法,

裸的二分图,这个题我用了挑战书上的二分图算法,用vector,结果就是 超空间。





#include<bits/stdc++.h>
using namespace std;
int g[220][220];
bool used[220];
int n,m,linker[220];

bool dfs(int u){
    for (int i = 0; i < m; i++)
        if (g[u][i] && !used[i])
        {
            used[i]=1;
            if (linker[i]==-1 || dfs(linker[i])){
                linker[i] = u;
                return 1;

            }
        }
    return false;
}
int big_matching(){
    int res = 0;
    memset(linker,-1,sizeof(linker));
    for (int i = 0; i < n; i++){
        memset(used,0,sizeof(used));
        if (dfs(i)) res++;
    }
    return res;
}
int main() {
    int tt,v;
    while(scanf("%d%d",&n,&m)==2){
        memset(g,0,sizeof(g));
        for (int i = 0; i < n; i++){
            scanf("%d",&tt);
            for (int j = 0; j < tt; j++){
                scanf("%d",&v);
                g[i][v-1] = 1;
            }
        }
       printf("%d\n",big_matching());
    }
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值