Dinner 09(水题)

Dinner

时间限制:100 ms  |  内存限制:65535 KB

难度:1

描述

Little A is one member of ACM team. He had justwon the gold in World Final. To celebrate, he decided to invite all to have onemeal. As bowl, knife and other tableware is not enough in the kitchen, Little Agoes to take backup tableware in warehouse. There are many boxes in warehouse,one box contains only one thing, and each box is marked by the name of thingsinside it. For example, if "basketball" is written on the box, whichmeans the box contains only basketball. With these marks, Little A wants tofind out the tableware easily. So, the problem for you is to help him, find outall the tableware from all boxes in the warehouse.

输入

Thereare many test cases. Each case contains one line, and one integer N at thefirst, N indicates that there are N boxes in the warehouse. Then N stringsfollow, each string is one name written on the box.

输出

Foreach test of the input, output all the name of tableware.

样例输入

3basketball fork chopsticks

2bowl letter

样例输出

forkchopsticks

bowl

提示

Thetableware only contains: bowl, knife, fork and chopsticks.


代码如下:

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main()  
{  
    int n,y;  
    char x;  
    scanf("%d",&n);  
    getchar();  
    while(n--)  
    {  
        scanf("%c%d",&x,&y);  
        if(x < 'a')  //代表都是大写字母 
        printf("%d\n",x-'A'+1+y);  
        else  //剩下就是小写字母 
        printf("%d\n",'a'-x-1+y);  
        getchar();  
    }  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值