Dinner(南阳oj218)(水题,主要是测试数据太弱了)

Dinner

时间限制: 100 ms  |  内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示

The tableware only contains: bowl, knife, fork and chopsticks.


这道题测试数据在nyoj系统上面实在是太弱了。  输入重复的餐具输出重复餐具或者是输出不重名餐具都是可以AC的,我真的服,因为这完全是两种不同的情况



当输入重复的的餐具名输入重复重复名时代码:

#include<stdio.h>
#include<string.h>
int main()
{
	char s[1000][20];
	int i,n;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		    scanf("%s",s[i]);
		int num=0;
		for(i=0;i<n;i++)
		{
			if((strcmp(s[i],"bowl")==0))
			{
				num++;
				if(num==1)
				   printf("bowl");
				else
				   printf(" bowl");
			}
			if((strcmp(s[i],"knife")==0))
			{
				num++;
				if(num==1)
				   printf("knife");
				else
				   printf(" knife");
		    }
		    if((strcmp(s[i],"fork")==0))
		    {
		    	num++;
		    	if(num==1)
		    	   printf("fork");
		    	else
		    	   printf(" fork");
			}
			if((strcmp(s[i],"chopsticks")==0))
			{
				num++;
				if(num==1)
				   printf("chopsticks");
				else
				   printf(" chopsticks");
			}
		}
		printf("\n");
	}
}


当输入重复餐具,但是输出唯一餐具时代码:


#include<stdio.h>
#include<string.h>
int main()
{
	char s[1000][20];
	int i,n;
	int vis[4];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		    scanf("%s",s[i]);
		int num=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++)
		{
			if(!vis[0]&&(strcmp(s[i],"bowl")==0))
			{
				vis[0]=1;
				num++;
				if(num==1)
				   printf("bowl");
				else
				   printf(" bowl");
			}
			if(!vis[1]&&(strcmp(s[i],"knife")==0))
			{
				vis[1]=1;
				num++;
				if(num==1)
				   printf("knife");
				else
				   printf(" knife");
		    }
		    if(!vis[2]&&(strcmp(s[i],"fork")==0))
		    {
		    	vis[2]=1;
		    	num++;
		    	if(num==1)
		    	   printf("fork");
		    	else
		    	   printf(" fork");
			}
			if(!vis[3]&&(strcmp(s[i],"chopsticks")==0))
			{
				vis[3]=1;
				num++;
				if(num==1)
				   printf("chopsticks");
				else
				   printf(" chopsticks");
			}
		}
		printf("\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值