poj1113Wall【凸包】

博客介绍了poj1113Wall问题的解决思路,重点在于计算凸包的周长,并结合半径为l的圆的周长进行解答。内容引用了http://blog.csdn.net/zhengnanlee/article/details/9633357中的图片来辅助理解,整个解决方案涉及几何计算和算法应用。
摘要由CSDN通过智能技术生成

Language:
Wall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32437 Accepted: 11008

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

题意:在距城堡距离大于L的地方建围墙将城堡围起来求所要围墙的长度;

图片转自:http://blog.csdn.net/zhengnanlee/article/details/9633357


所以所求长度如图所示为凸包周长加以l为半径的圆的周长。因为绕周长一周所以为一个正圆

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define PI 3.1415926
#define eps 1e-8
using namespace std;
struct point{
	double x,y;
}A[1010],result[1010];
bool equal(double n){
	return fabs(n-0)<eps;
}
double cp(point p1,point p2,point p3){
	return (p3.x-p1.x)*(p2.y-p1.y)-(p3.y-p1.y)*(p2.x-p1.x);
}
double dist(point a,point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp(point a,point b){
	double ans=cp(A[0],a,b);
	if(equal(ans))
		return dist(A[0],a)-dist(A[0],b)<=0;
	else 
		return ans>0;
}
int main()
{
	int n,i,j,l;
	while(scanf("%d%d",&n,&l)!=EOF){
		int pos=0;
		for(i=0;i<n;++i){
			scanf("%lf%lf",&A[i].x,&A[i].y);
			if(A[pos].y>=A[i].y){
				if(A[pos].y==A[i].y){
					if(A[pos].x>A[i].x)pos=i;
				}
				else pos=i;
			}
		}
		double S=0;
		point temp;
		temp=A[pos];A[pos]=A[0];A[0]=temp;
		sort(A+1,A+n,cmp);
		int top=1;
		result[0]=A[0];
		result[1]=A[1];
		for(i=2;i<n;++i){
			while(cp(result[top-1],result[top],A[i])<0)top--;
			result[++top]=A[i];
		}
		for(i=0;i<=top;++i){
			S+=dist(result[(i+1)%(top+1)],result[i]);
		}
		printf("%.0lf\n",S+2.0*PI*l);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值