poj1434Fill the Cisterns!【二分+计算几何】

Language:
Fill the Cisterns!
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 3648 Accepted: 1224

Description

During the next century certain regions on earth will experience severe water shortages. The old town of Uqbar has already started to prepare itself for the worst. Recently they created a network of pipes connecting the cisterns that distribute water in each neighbourhood, making it easier to fill them at once from a single source of water. But in case of water shortage the cisterns above a certain level will be empty since the water will to the cisterns below. 


You have been asked to write a program to compute the level to which cisterns will be lled with a certain volume of water, given the dimensions and position of each cistern. To simplify we will neglect the volume of water in the pipes. 


Task 

Write a program which for each data set: 

reads the description of cisterns and the volume of water, 

computes the level to which the cisterns will be filled with the given amount of water, 

writes the result. 

Input

The first line of the input contains the number of data sets k, 1 <= k <= 30. The data sets follow. 

The first line of each data set contains one integer n, the number of cisterns, 1 <= n <= 50 000. Each of the following n lines consists of 4 nonnegative integers, separated by single spaces: b, h, w, d - the base level of the cistern, its height, width and depth in meters, respectively. The integers satisfy 0 <= b <= 10^6 and 1 <= h * w * d <= 40 000. The last line of the data set contains an integer V - the volume of water in cubic meters to be injected into the network. Integer V satisfies 1 <= V <= 2 * 10^9. 

Output

The output should consist of exactly d lines, one line for each data set. 

Line i, 1 <= i <= d, should contain the level that the water will reach, in meters, rounded up to two fractional digits, or the word 'OVERFLOW', if the volume of water exceeds the total capacity of the cisterns. 

Sample Input

3
2
0 1 1 1
2 1 1 1
1
4
11 7 5 1
15 6 2 2
5 8 5 1
19 4 8 1
132
4
11 7 5 1
15 6 2 2
5 8 5 1
19 4 8 1
78

Sample Output

1.00
OVERFLOW
17.00


题意:求将体积为V的水倒入上图所示结构水位能到达的最大高度

解题思路二分

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define eps 1e-8
#define inf 0x3f3f3f3f
using namespace std;
struct Node{
	double l,h,w,d;
}A[50010];
double MIN(double a,double b){
	return a<b?a:b;
}
double MAX(double a,double b){
	return a>b?a:b;
}
int main()
{
	int t,i,j,n;
	double volum,left,right,v=0;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		left=inf;right=0;v=0;
		for(i=0;i<n;++i){
			scanf("%lf%lf%lf%lf",&A[i].l,&A[i].h,&A[i].w,&A[i].d);
			v+=A[i].h*A[i].w*A[i].d;
			left=MIN(A[i].l,left);
			right=MAX(A[i].h+A[i].l,right);
		}
		scanf("%lf",&volum);
		if(volum-v>eps){
			printf("OVERFLOW\n");
			continue;
		}
		while(right-left>eps){
			double mid=(left+right)/2.0;v=0;
			for(i=0;i<n;++i){
				if(mid-A[i].l>=0){
					if(mid-(A[i].h+A[i].l)>=0){
						v+=A[i].d*A[i].h*A[i].w;
					}
					else{
						v+=A[i].d*A[i].w*(mid-A[i].l);
					}
				}
			}
			if(v>=volum){
				right=mid;
			}
			else{
				left=mid;
			}
		} 
		printf("%.2lf\n",right);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值