【bzoj 3942】[Usaco2015 Feb]Censoring(栈+kmp)

27 篇文章 0 订阅
14 篇文章 0 订阅

3942: [Usaco2015 Feb]Censoring

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 317   Solved: 177
[ Submit][ Status][ Discuss]

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

 
 

Input

The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
 
 

Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
 
 

Sample Input

whatthemomooofun
moo

Sample Output

whatthefun

HINT

Source

[ Submit][ Status][ Discuss]

【题解】【栈+kmp】

【依次将每一位上的字符压入栈中,每次成功匹配出一个子串就从栈中弹出子串长度的序列,并将T串的指针指回栈顶元素所对应指针位置的下一位置】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[1000010],b[1000010],d[1000010];
int la,lb,nxt[1000010],top,f[1000010];
inline void kmp()
{
	int i,j;
	nxt[0]=-1;
	for(i=0;i<lb;++i)
	 {
	 	j=nxt[i];
	 	while(j!=-1&&b[j]!=b[i]) j=nxt[j];
	 	nxt[i+1]=j+1;
	 }
}
int main()
{
	int i,j;
	gets(a); gets(b);
	la=strlen(a); lb=strlen(b);
	kmp(); 
	i=0; j=0; int last=0;
	while(i!=la)
	 {
	 	if(a[i]==b[j]||j==-1) d[++top]=a[i],f[top]=j,i++,j++;
	 	 else j=nxt[j];
	 	if(j==lb) top-=j,j=f[top]+1;
	 }
	for(i=1;i<=top;++i) printf("%c",d[i]);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值