Censoring【KMP算法+堆栈模拟】

21 篇文章 1 订阅

Censoring

传送门:链接   来源:UPC8203

题目描述

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete.

输入

The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z). 

输出

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process. 

 

样例输入

whatthemomooofun
moo

样例输出

whatthefun

题目大意:

   给出a,p两个字符串从a中消去所有的p,直到不能消去为止。

思路分析:

尝试了三种做法:

1、直接vector删除,结果TLE。

2、Next[]数组+vector删除,结果TLE(应该是哪里bug死循环了,现在也没找到原因,估计是kmp的代码不行)。

3、看了别人的题解:传送门,发现可以用堆栈模拟来做。(下面讲的就是这种方法)

之前一想到删除操作第一反应就是vector,看来以后也要考虑堆栈了,用vector应该也行。

看上面博客写的kmp代码和我的不太一样,顺便学习了一下他的代码。

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const LL MAX=1e6;
LL Next[MAX+5],flag[MAX+5];
char Stack[MAX+5];
void getNext(string p,LL lp,LL Next[]){
    LL k=0;
    for(LL i=1;i<lp;i++){
        while(k&&p[i]!=p[k]) k=Next[k];
        if(p[i]==p[k]) k++;
        Next[i+1]=k;
    }
}
void kmp(string a,string p,LL la,LL lp){
    LL j=0,top=0;
    for(LL i=0;i<la;i++){
        Stack[++top]=a[i];
        while(j&&a[i]!=p[j]) j=Next[j];
        if(a[i]==p[j]) j++;
        if(j==lp) top-=lp,j=flag[top];
        flag[top]=j;
    }
    for(int i=1;i<=top;i++){ ///堆栈中剩余的都是没被删除的,直接输出就行了。
        cout<<Stack[i];
    }
    cout<<endl;
}
int main()
{
    string a,p;
    cin>>a>>p;
    LL la=a.size(),lp=p.size();
    getNext(p,lp,Next);
    kmp(a,p,la,lp);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值