HDU1702 ACboy needs your help again!(队列和栈)

题目:

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6094    Accepted Submission(s): 3197


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
  
  
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
  
  
1 2 2 1 1 2 None 2 3
 

Source
代码:

#include <stdio.h>
#include <stack>
#include <cstring>
#include <queue>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);//数据的组数
    while(t--)
    {
        int n;
        queue<int> q;//先声明一个队列和一个栈
        stack<int> s;
        char str[10];
        scanf("%d %s",&n,str);
        if(strcmp(str,"FIFO")==0)//判断输入要求的是队列
        {
            while(n--)//指令的组数
            {
                char zl[10];
                int x;
                scanf("%s",zl);
                if(strcmp(zl,"IN")==0)
                {
                    scanf("%d",&x);
                    q.push(x);//如果是输入的指令,就把输入的值加入队列
                }
                else if(strcmp(zl,"OUT")==0)//如果是出的指令
                {
                    if(!q.empty())//当队列非空时
                    {
                        printf("%d\n",q.front());//打印队首,并抛弃队首元素
                        q.pop();
                    }
                    else
                    {
                        printf("None\n");
                    }
                }
            }
        }
        else if(strcmp(str,"FILO")==0)//判断输入要求的是栈
        {
            while(n--)//命令的组数
            {
                char zl[10];
                int x;
                scanf("%s",zl);
                if(strcmp(zl,"IN")==0)
                {
                    scanf("%d",&x);
                    s.push(x);//如果是输入的指令,就把输入的值加入栈
                }
                else if(strcmp(zl,"OUT")==0)
                {
                    if(!s.empty())//当栈非空时
                    {
                        printf("%d\n",s.top());//打印栈顶元素,并出栈
                        s.pop();
                    }
                    else
                    {
                        printf("None\n");
                    }
                }
            }
        }

    }
    return 0;
}
PS:队列和栈的一道很简单的练习题,帮助理解概念

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值