UVA 1636 Headshot

You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on a
cylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun’s
barrel. When trigger of the gun is pulled, the gun’s cylinder rotates, aligning the next chamber with the
barrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamber
is empty when the hammer strikes it, then there is no shot but just a “click”.
You have found a use for this gun. You are playing Russian Roulette with your friend. Your friend
loads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with a
gun’s barrel, puts the gun to his head and pulls the trigger. You hear “click” and nothing else — the
chamber was empty and the gun did not shoot.
Now it is your turn to put the gun to your head and pull the trigger. You have a choice. You
can either pull the trigger right away or you can randomly rotate the gun’s cylinder and then pull the
trigger. What should you choose to maximize the chances of your survival?
Input
The input file contains several datasets. A dataset consists of a single line with a string of n digits ‘0’
and ‘1’ (2 ≤ n ≤ 100). This line of digits represents the pattern of rounds that were loaded into the
gun’s chambers. ‘0’ represent an empty chamber, ‘1’ represent a loaded one. In this representation,
when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for a
shot. Since the chambers are actually located on a circle, the first chamber in this string follows the
last one. There is at least one ‘0’ in this string.
Output
For each dataset, write to the output file one of the following words (without quotes):
• ‘SHOOT’ — if pulling the trigger right away makes you less likely to be actually shot in the head
with the bullet (more likely that the chamber will be empty).
• ‘ROTATE’ — if randomly rotating the cylinder before pulling the trigger makes you less likely to
be actually shot in the head with the bullet (more likely that the chamber will be empty).
• ‘EQUAL’ — if both of the above choices are equal in terms of probability of being shot.
Sample Input
0011
0111
000111
Sample Output
EQUAL
ROTATE
SHOOT


给出手枪里子弹的一个环形序列,有一些位置有子弹,有一些位置没有。每次扣动扳机以后对准下一个位置。
扣动扳机,发现没子弹。再扣一次,有子弹和没子弹的概率哪个大?
直接射击没有子弹的概率是(00的个数)/(0的个数)。
转一下再射击没有子弹的概率是(0的个数)/(总数)。


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char ch[110];
int l,cnt_0,cnt_00;
int main()
{
    while(scanf("%s",ch+1)==1)
    {
        l=strlen(ch+1);
        cnt_0=0,cnt_00=0;
        for(int i=1;i<=l;i++)
            if(ch[i]=='0')
            {
                ++cnt_0;
                if((i<l&&ch[i+1]=='0')||(i==l&&ch[1]=='0'))
                    ++cnt_00;
            }
        if(cnt_00*l>cnt_0*cnt_0)
            printf("SHOOT\n");
        else if(cnt_00*l<cnt_0*cnt_0)
            printf("ROTATE\n");
        else
            printf("EQUAL\n");
    }
    return 0;
}
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值