UVa 1636 Headshot

You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on a
cylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun’s
barrel. When trigger of the gun is pulled, the gun’s cylinder rotates, aligning the next chamber with the
barrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamber
is empty when the hammer strikes it, then there is no shot but just a “click”.
You have found a use for this gun. You are playing Russian Roulette with your friend. Your friend
loads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with a
gun’s barrel, puts the gun to his head and pulls the trigger. You hear “click” and nothing else — the
chamber was empty and the gun did not shoot.
Now it is your turn to put the gun to your head and pull the trigger. You have a choice. You
can either pull the trigger right away or you can randomly rotate the gun’s cylinder and then pull the
trigger. What should you choose to maximize the chances of your survival?
Input
The input file contains several datasets. A dataset consists of a single line with a string of n digits ‘0’
and ‘1’ (2 ≤ n ≤ 100). This line of digits represents the pattern of rounds that were loaded into the
gun’s chambers. ‘0’ represent an empty chamber, ‘1’ represent a loaded one. In this representation,
when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for a
shot. Since the chambers are actually located on a circle, the first chamber in this string follows the
last one. There is at least one ‘0’ in this string.
Output
For each dataset, write to the output file one of the following words (without quotes):
• ‘SHOOT’ — if pulling the trigger right away makes you less likely to be actually shot in the head
with the bullet (more likely that the chamber will be empty).
• ‘ROTATE’ — if randomly rotating the cylinder before pulling the trigger makes you less likely to
be actually shot in the head with the bullet (more likely that the chamber will be empty).
• ‘EQUAL’ — if both of the above choices are equal in terms of probability of being shot.

Sample Input

0011
0111
000111

Sample Output

EQUAL
ROTATE
SHOOT


【分析】
水题,计算出0出现的概率和00出现的概率进行比较即可。
注意要用十字相乘法,而且注意第一位和最后一位都是0的情况。


【代码】

//UVa 1636 Headshot
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
char s[1005];
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch>'9'||ch<'0'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int main()
{
    int i,j;
    while(scanf("%s",s+1)==1)
    {
        int l=strlen(s+1),t00=0,t0=0;
        if(s[1]=='0') t0++;
        if(s[1]=='0' && s[l]=='0') t00++;
        fo(i,2,l)
        {
            if(s[i]=='0') t0++;
            if(s[i]=='0' && s[i-1]=='0') t00++;
        }
        if(t0*t0>t00*l) printf("ROTATE\n");
        else if(t0*t0==t00*l) printf("EQUAL\n");
        else printf("SHOOT\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值