POJ 1422 Air Raid

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town’s streets you can never reach the same intersection i.e. the town’s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
……
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town’s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3
Sample Output

2
1
Source

Dhaka 2002

就是最小路径覆盖=总数-最大匹配。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int N=125;
int T,n,m,ans,lft[N];
bool vis[N],d[N][N];
bool dfs(int u)
{
    for(int i=1;i<=n;i++)
        if(d[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(lft[i]==-1||dfs(lft[i]))
            {
                lft[i]=u;
                return 1;
            }
        }
    return 0;
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        ans=0;
        memset(d,0,sizeof(d));
        scanf("%d%d",&n,&m);
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            d[x][y]=1;
        }
        memset(lft,-1,sizeof(lft));
        for(int i=1;i<=n;++i)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ++ans;
        }
        printf("%d\n",n-ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值