Description
With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
Input
no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets
The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
Sample Output
2 1
//
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=600;//N不能太大 否则超时
int cap[N][N];//初始化要清零
int _link[N];
bool used[N];
int nx,ny;//1->nx
bool _find(int t)
{
for(int i=1;i<=ny;i++)
if(!used[i]&&cap[t][i]==1)
{
used[i]=true;
if(_link[i]==-1||_find(_link[i]))
{
_link[i]=t;
return true;
}
}
return false;
}
int MaxMatch()
{
int num=0;
memset(_link,-1,sizeof(_link));
for(int i=1;i<=nx;i++)
{
memset(used,false,sizeof(used));
if(_find(i)) num++;
}
return num;
}
int main()
{
int ci;scanf("%d",&ci);
while(ci--)
{
int n,m;
scanf("%d%d",&n,&m);
nx=ny=n;
memset(cap,0,sizeof(cap));
for(int i=0;i<m;i++)
{
int x,y;scanf("%d%d",&x,&y);
cap[x][y]=1;
}
int ans=MaxMatch();
printf("%d\n",n-ans);
}
return 0;
}