Project Euler #1: Multiples of 3 and 5

If we list all the natural numbers below 10 that are multiples of 3 or 5, we get 3, 5, 6 and 9. The sum of these multiples is 23.

Find the sum of all the multiples of 3 or 5 below N .

Input Format
First line contains T that denotes the number of test cases. This is followed by T lines, each containing an integer, N .

Output Format
For each test case, print an integer that denotes the sum of all the multiples of 3 or 5 below N .

Constraints
1T105
1N109

Sample Input

2
10
100

Sample Output

23
2318 
 
 

Language: C


     
     
1
#include <stdio.h>
2
#include <stdlib.h>
3
4
int main()
5
{
6
    unsigned long long int N,i,j,x,y,z;
7
    int T;
8
    scanf("%d",&T);
9
    unsigned long long int n[T];
10
    for(i=1;i<=T;i++)
11
    {
12
        scanf("%llu",&N);
13
        x=(N-1)/3;
14
        y=(N-1)/5;
15
        z=y/3;
16
        n[i-1]=(3+3*x)*x/2;
17
        n[i-1]+=(5+5*y)*y/2;
18
        n[i-1]-=(15+15*z)*z/2;
19
    }
20
    for(i=1;i<=T;i++)
21
    {
22
        printf("%llu\n",n[i-1]);
23
    }
24
    return 0;
25
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值