树形DP-POJ-2342-Anniversary party

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7067 Accepted: 4072
Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5
Source

Ural State University Internal Contest October’2000 Students Session


题意:
有N个人,每个人有一个直属上司,有一个自己的评价值(-128~127),现在要你从中选出一部分人,使得直属上司与下属不能同时存在,并且总评价值最大。
题中保证上司下属关系不会成环


题解:
由于上司与下属关系是一棵树,很明显的树形DP,我本来是想找一道难一点的双向树形DP做做以应付区域赛,但是搜到这个一眼题就顺手水了。
因为每个人只会有选与不选两种状态,那么DP数组可建成dp[maxn][2],其中dp[i][1]表示在选了第i个人的情况下,合理方案中最大的评价值,dp[i][0]反之表示不选。
那么可以知道,若j是i的直属下属,则有dp[i][1]=dp[i][1]+dp[j][0],同理dp[i][0]=dp[i][0]+max(dp[j][1],dp[j][0])。则直接从根开始DFS,到叶子节点后回溯DP即可。


//
//  main.cpp
//  POJ-2342-Anniversary party
//
//  Created by 袁子涵 on 16/9/16.
//  Copyright © 2016年 袁子涵. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <algorithm>
#include <set>
#include <vector>
#include <queue>
#include <utility>
#include <map>

using namespace std;
const int maxn=6005;
int n;
vector<int>son[maxn];
int dp[maxn][2],root=1,fa[maxn];
void TreeDP(int now)
{
    for(int i=0;i<son[now].size();i++)
    {
        int ss=son[now][i];
        TreeDP(ss);
        dp[now][1]+=dp[ss][0];
        dp[now][0]+=max(dp[ss][0],dp[ss][1]);
    }
}
int main(int argc, const char * argv[]) {
    int s,f;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&dp[i][1]);
    for(int i=1;i<n;i++)
    {
        scanf("%d%d",&s,&f);
        son[f].push_back(s);
        fa[s]=f;
    }
    scanf("%d%d",&s,&f);
    while(fa[root])
        root=fa[root];
    TreeDP(root);
    printf("%d\n",max(dp[root][0],dp[root][1]));

    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值