Hdu 1028 Ignatius and the Princess III(整数拆分问题,DP)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18932    Accepted Submission(s): 13303


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627

 整数划分问题是算法中的一个经典命题之一,有关这个问题的讲述在讲解到递归时基本都将涉及。所谓整数划分,是指把一个正整数n写成如下形式:

       n=m1+m2+...+mi; (其中mi为正整数,并且1 <= mi <= n),则{m1,m2,...,mi}n的一个划分。

       如果{m1,m2,...,mi}中的最大值不超过m,即max(m1,m2,...,mi)<=m,则称它属于n的一个m划分。这里我们记nm划分的个数为f(n,m);

       例如但n=4时,他有5个划分,{4},{3,1},{2,2},{2,1,1},{1,1,1,1};

       注意4=1+3  4=3+1被认为是同一个划分。

       该问题是求出n的所有划分个数,即f(n, n)。下面我们考虑求f(n,m)的方法

 根据nm的关系,考虑以下几种情况:

       1)当n=1时,不论m的值为多少(m>0),只有一种划分即{1};

        (2) m=1时,不论n的值为多少,只有一种划分即n1{1,1,1,...,1};

        (3) n=m时,根据划分中是否包含n,可以分为两种情况:

              (a). 划分中包含n的情况,只有一个即{n}

              (b). 划分中不包含n的情况,这时划分中最大的数字也一定比n小,即n的所有(n-1)划分。

              因此 f(n,n) =1 + f(n,n-1);

        (4) n<m时,由于划分中不可能出现负数,因此就相当于f(n,n);

        (5) n>m时,根据划分中是否包含最大值m,可以分为两种情况:

               (a). 划分中包含m的情况,即{m, {x1,x2,...xi}}, 其中{x1,x2,... xi} 的和为n-m,因此这种情况下

                 f(n-m,m)

               (b). 划分中不包含m的情况,则划分中所有值都比m小,即n(m-1)划分,个数为f(n,m-1);

              因此 f(n, m) = f(n-m, m)+f(n,m-1);

      综上所述:

                             f(n, m)=   1;                (n=1 or m=1)

                             f(n, n);                        (n<m)

                             1+ f(n, m-1);                (n=m)

                             f(n-m,m)+f(n,m-1);      (n>m)

#include <iostream>
#include <string>
#include<cstdio>

using namespace std;

const int M=120;
int dp[M+1][M+1]; //p[i][j]表示i能被分成不大于j的数之和的方法数

int main()
{
    int n,i,j;
    for(i=1;i<=M;i++)
        for(j=1;j<=M;j++)
        {
            if(j>i)
                dp[i][j]=dp[i][i];
            else if(i==j)
                dp[i][j]=dp[i][i-1]+1;
            else
                dp[i][j]=dp[i][j-1]+dp[i-j][j];
        }
    while(scanf("%d",&n)!=EOF)
    {
        cout<<dp[n][n]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值