POJ2975——Nim(经典nim变种)

Nim
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5556 Accepted: 2604

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

题目实在是,有点绕。

简单来说就是先手有多少种方案使得后继态变成必败态。

我们都知道在nim中,所有石子堆得异或和为0时为必败态。

那么题目就变成了,有多少堆石子,在减少其一定数目时,可以变为必败态。

假设第i堆石子是可以实现的,在其石子数变为k时,总的异或和为0.

我们求出这个k为多少?

我们知道,0异或任何数等于它本身,一个数异或它本身为0.

所以总得异或值异或a[i]就等于除了i堆石子外的异或值。记为s

那么s再异或s就变成了0.

那么只要a[i]大于s就能使其变为必败态。


#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
using namespace std;
const int MAXN =1010;
const long long INF =0x3f3f3f3f ;
const long long MOD =(1ll<<32);

int a[MAXN];
int n;
int main(){
    while(scanf("%d",&n)&&n){
        int s=0;
        for(int i=0;i<n;i++){
            scanf("%d",a+i);
            s^=a[i];
        }
        int cnt=0;
        for(int i=0;i<n;i++){
            if(a[i]>(s^a[i]))
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值