Nim(Nim博弈变形)

18 篇文章 0 订阅
6 篇文章 0 订阅


Link:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4675


Nim

Time Limit: 3 Seconds       Memory Limit: 65536 KB

Nim is a mathematical game of strategy in which two players take turns removing objects from distinct heaps. The game ends when one of the players is unable to remove object in his/her turn. This player will then lose. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap. Here is another version of Nim game. There are N piles of stones on the table. Alice first chooses some CONSECUTIVE piles of stones to play the Nim game with Tom. Also, Alice will make the first move. Alice wants to know how many ways of choosing can make her win the game if both players play optimally.

You are given a sequence a[0],a[1], ... a[N-1] of positive integers to indicate the number of stones in each pile. The sequence a[0]...a[N-1] of length N is generated by the following code:

 	
 	
 
 
int g = S; 
for (int i=0; i<N; i++) { 
    a[i] = g;
    if( a[i] == 0 ) { a[i] = g = W; }
    if( g%2 == 0 ) { g = (g/2); }
    else           { g = (g/2) ^ W; }
}

Input

There are multiple test cases. The first line of input is an integer T(T ≤ 100) indicates the number of test cases. Then T test cases follow. Each test case is represented by a line containing 3 integers NS and W, separated by spaces. (0 < N ≤ 105, 0 < S, W ≤ 109)

Output

For each test case, output the number of ways to win the game.

Sample Input
2
3 1 1
3 2 1
Sample Output
4
5

Author:  CAO, Peng
Contest:  The 12th Zhejiang University Programming Contest


编程思想:博弈+求逆反面思想


AC code:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#define LL long long
#define M 1100010
using namespace std;
int a[100100],b[100100];
LL ans,dd;
int main()
{
	int N,S,W,T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&N,&S,&W);
		int g = S; 
		for (int i=0; i<N; i++) { 
		    a[i] = g;
		    if( a[i] == 0 ) { a[i] = g = W; }
		    if( g%2 == 0 ) { g = (g/2); }
		    else           { g = (g/2) ^ W; }
		}
		ans=(LL)(1+N)*N/2;//必须强加LL转换为long long,否则 (1+N)*N/2超int型,而N是int,所以会溢出int,导致WA!!! 
		int tmp=0;
		for(int i=0;i<N;i++)
		{
			tmp^=a[i];
			b[i]=tmp;
		}
		sort(b,b+N);
		int bb=b[0];
		dd=0;
		LL cnt=1;
		for(int i=1;i<N;i++)
		{
			if(bb==b[i])
			{
				cnt++;
			}
			else
			{
				if(bb==0) dd+=cnt;//为0的话,从第0堆到i堆这一组是必败局面,要减掉 
				dd+=(LL)cnt*(cnt-1)/2;
				cnt=1;
				bb=b[i];
			}
		}
		dd+=(LL)cnt*(cnt-1)/2;
		ans-=dd;
		printf("%lld\n",ans);
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值