蓝桥杯-5-1最小公倍数(java)

                         算法训练 5-1最小公倍数  
                    时间限制:1.0s   内存限制:256.0MB

            问题描述
              编写一函数lcm,求两个正整数的最小公倍数。
            样例输入
            一个满足题目要求的输入范例。
            例:

            3 5
            样例输出
            与上面的样例输入对应的输出。
            例:
            数据规模和约定
              输入数据中每一个数的范围。
              例:两个数都小于65536。
public class Main{  
        public static void main(String[] args) {    
            Scanner sc = new Scanner(System.in);    
            int a = sc.nextInt();    
            int b = sc.nextInt();    
            sc.close();    
            System.out.println(lcm(a, b));    
        }    

        private static int lcm(int a, int b) {    
            int g = gcd(a, b);    
            return a * b / g;    
        }    

        private static int gcd(int a, int b) {    
            if (b == 0) {    
                return a;    
            } else {    
                return gcd(b, a % b);  //辗转相除法  
            }    
        }    
    } 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hello-java-maker

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值