SDAU 贪心专题 17 小箱子

1:问题描述

Problem Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last “null” line of the input file.

Sample Input

0 0 4 0 0 1

7 5 1 0 0 0

0 0 0 0 0 0

Sample Output

2 1

2:大致题意

输入6个数据,分别是1*1,2*2,3*3,4*4,5*5,6*6箱子的个数。将这些箱子装在6*6的箱子​里面,求出需要最少的箱子数。箱子不能重叠。因为箱子的高度都是h。

3:思路

从最大的开始考虑。

(1)如果是6*6的箱子,那么它必须得占一个箱子而且​不能装其他的箱子了。

(2)如果是5*5的箱子,它也必须占一个箱子,不过装上一个5*5之后还可以装11个1*1的箱子。这里要做判断。

(3)如果是4*4的箱子,必须占一个箱子,装上之后还可以装2*2和1*1的箱子。

(4)略。(n个if else 判断就好啦)

4:感想

大致思路就是这样的,一次一次的检索。挺烧脑的一个题。思路必须特别清晰。​​如果有地方没有考虑周到,一直WA也是很苦逼的。比如说某赫。偷笑~~~

这道题是和某豆豆一起完成的,有机智的ww在(还有一旁不服气的的小豆豆),当然一遍就过啦。​

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
using namespace std;
int main()
{
    //freopen("r.txt", "r", stdin);
    int a[10];
    int i,b,num,last;
    while(cin>>a[1])
    {
        int count=0;
        for(i=2;i<=6;i++)
            cin>>a[i];
        for(i=1;i<=6;i++)
            if(a[i]==0) count++;
        if(count==6) break;

        num=a[6];
        if(a[5]>0)
        {
            num+=a[5];
            if((a[5]*11)>=a[1])
            {
                a[1]=0;
            }
            else
            {
                a[1]-=a[5]*11;
            }
        }
        if(a[4]>0)
        {
            num+=a[4];
            if(a[4]*5>=a[2])
            {
                last=36*a[4]-a[4]*16-a[2]*4;
                a[2]=0;
                if(a[1]>0)
                {
                    if(last>=a[1])
                    {
                        a[1]=0;
                    }
                    else
                    {
                        a[1]-=last;
                    }
                }

            }
            else
            {
                a[2]-=a[4]*5;
            }
        }
        if(a[3]>0)
        {
            num+=a[3]/4;
            a[3]%=4;
            if(a[3]!=0)
            {
                num++;
                last=36-a[3]*9;
                if(a[3]==3)
                {
                    if(a[2]!=0)
                    {
                        a[2]--;
                        if(a[1]>5)
                        {
                            a[1]-=5;
                        }
                        else
                        {
                            a[1]=0;
                        }
                    }
                    else
                    {
                        if(a[1]>9)
                        {
                            a[1]-=9;
                        }
                        else
                        {
                            a[1]=0;
                        }
                    }
                }
                if(a[3]==2)
                {
                    if(a[2]>3)
                    {
                        a[2]-=3;
                        if(a[1]>6)
                        {
                            a[1]-=6;
                        }
                        else
                        {
                            a[1]=0;
                        }
                    }
                    else
                    {
                        last=18-a[2]*4;
                        a[2]=0;
                        if(a[1]>last)
                        {
                            a[1]-=last;
                        }
                        else
                        {
                            a[1]=0;
                        }

                    }
                }
                if(a[3]==1)
                {
                    if(a[2]>5)
                    {
                        a[2]-=5;
                        if(a[1]>7)
                        {
                            a[1]-=7;
                        }
                        else
                        {
                            a[1]=0;
                        }
                    }
                    else
                    {
                        last=36-9-a[2]*4;
                        a[2]=0;
                        if(a[1]>last)
                        {
                            a[1]-=last;
                        }
                        else
                        {
                            a[1]=0;
                        }
                    }
                }
            }
        }
        if(a[2]>0)
        {
            num+=a[2]/9;
            a[2]%=9;
            if(a[2]!=0)
            {
                num++;
                last=36-a[2]*4;
                if(a[1]>last)
                {
                    a[1]-=last;
                }
                else
                {
                    a[1]=0;
                }
            }
        }
        if(a[1]>0)
        {
            num+=a[1]/36;
            a[1]%=36;
            if(a[1]!=0)
            {
                num++;
            }
        }
        cout<<num<<endl;
    }
}


智慧旅游解决方案利用云计算、物联网和移动互联网技术,通过便携终端设备,实现对旅游资源、经济、活动和旅游者信息的智能感知和发布。这种技术的应用旨在提升游客在旅游各个环节的体验,使他们能够轻松获取信息、规划行程、预订票务和安排食宿。智慧旅游平台为旅游管理部门、企业和游客提供服务,包括政策发布、行政管理、景区安全、游客流量统计分析、投诉反馈等。此外,平台还提供广告促销、库存信息、景点介绍、电子门票、社交互动等功能。 智慧旅游的建设规划得到了国家政策的支持,如《国家中长期科技发展规划纲要》和国务院的《关于加快发展旅游业的意见》,这些政策强调了旅游信息服务平台的建设和信息化服务的重要性。随着技术的成熟和政策环境的优化,智慧旅游的时机已经到来。 智慧旅游平台采用SaaS、PaaS和IaaS等云服务模式,提供简化的软件开发、测试和部署环境,实现资源的按需配置和快速部署。这些服务模式支持旅游企业、消费者和管理部门开发高性能、高可扩展的应用服务。平台还整合了旅游信息资源,提供了丰富的旅游产品创意平台和统一的旅游综合信息库。 智慧旅游融合应用面向游客和景区景点主管机构,提供无线城市门户、智能导游、智能门票及优惠券、景区综合安防、车辆及停车场管理等服务。这些应用通过物联网和云计算技术,实现了旅游服务的智能化、个性化和协同化,提高了旅游服务的自由度和信息共享的动态性。 智慧旅游的发展标志着旅游信息化建设的智能化和应用多样化趋势,多种技术和应用交叉渗透至旅游行业的各个方面,预示着全面的智慧旅游时代已经到来。智慧旅游不仅提升了游客的旅游体验,也为旅游管理和服务提供了高效的技术支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值