SDAU贪心专题 06 电梯

1:问题描述
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41
2:大致题意
这个题挺简单的。一个电梯,上一层需要6秒,下一层需要4秒,在指定楼层停留5秒。
输入指令,求时间。虽然这个题出现在贪心专题里面,但个人认为并没有用到贪心算法。一步一步算就行了。没有牵扯到最优解的问题。
3:思路
一次一次求即可,每次记录相应的楼层。下次输入指令时,先判断是上楼还是下楼。
当时考虑到,如果连续输入2个相同的指令的话,就应该不用停留了。因此wa一次。其实是需要加上5秒的。
4:感想
签到题。当时和某窦一起做的,虽然ac的比他早,但由于wa一次被罚时了��。这套题一直都是和某窦一起做的。我们说好要一起完成费老师的夙愿那(●’◡’●)。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
using namespace std;
int ww[105];
int main()
{
    int n,i,k,j,z;
    while(cin>>n&&n!=0)
    {
        int time=0;
        memset(ww,0,sizeof(ww));
        for(i=0;i<n;i++)
        {
            cin>>ww[i];
            if(i==0)
            {
                time+=6*ww[i]+5;
            }
            else
            {
                if(ww[i]>ww[i-1]) time+=6*(ww[i]-ww[i-1])+5;
                else time+=4*(ww[i-1]-ww[i])+5;
            }
        }
        cout<<time<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值