SDAU 贪心专题 02 田忌赛马

1:问题描述
Problem Description
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

2:大致题意
田忌赛马,输入田忌的马的战斗力,和秦王的马的战斗力。帮助田忌合理的安排马的出场的顺序,使他赢得更多的场次。赢一场可以得到200金,输一场失去200金。求出田忌可以赢得钱。

3:思路
(1) 如果田忌最坏的马比秦王最坏的马快,那么就让田忌赢。
(2)如果田忌最坏的马比秦王最坏的马慢,那么就用田忌最坏的马和秦王的最好的马比赛。
(3)如果相等的话:
1:再比较田忌的快马与秦王的快马,如果田忌的快马快,那么就让田忌赢。
2:如果秦王的快马快,那么还有两种情况,第一种情况是秦王的快马大于田忌的慢马,那么就田忌输,第二种情况是秦王的快马等于天际的慢马,那么就平局。

4:感想
这个题难点在怎么控制最快马与最慢马,还有已经比较过的马怎么记录下来。
排好序之后用下标记录,如果田忌的慢马比赛过了,就tmin++,如果快马比赛过了,就tmax–。这样就可以控制了。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
using namespace std;
int main()
{
    //freopen("ww.txt","ww",stdin);
    int t[2000],q[2000];
    int tmin,tmax,qmin,qmax;
    int n,m,i,j,k,z,sum;
    while(cin>>n&&n!=0)
    {
        for(i=0;i<n;i++)
            cin>>t[i];    //田忌的马的战斗力。
        for(i=0;i<n;i++)
            cin>>q[i];   //秦王的马的战斗力。
        sort(t,t+n);
        sort(q,q+n);
        tmax=n-1;        //田忌战斗力最高的马的下标。
        tmin=0;          //田忌战斗力最低的马的下标。
        qmax=n-1;        //秦王战斗力最高的马的下标
        qmin=0;          //秦王战斗力最低的马的下标。
        sum=0;
        while(tmax>=tmin)
        {
            if(t[tmin]>q[qmin])   /*如果田忌最坏的马,比秦王最坏的马要快。*/
            {
                sum+=200;
                tmin++;
                qmin++;
            }
            else if(t[tmin]<q[qmin])
            {
                tmin++;
                qmax--;
                sum-=200;
            }
                else
                {
                    if(t[tmax]>q[qmax])
                    {
                        sum+=200;
                        tmax--;
                        qmax--;
                    }
                    else
                    {
                         if(t[tmin]<q[qmax])
                        {
                            sum-=200;
                        }
                        tmin++;
                        qmax--;
                    }
                }

        }
        cout<<sum<<endl;
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值