模拟题字符串中元音辅音

Easier Done Than Said?
Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords
are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering
them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable”
passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the
generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

(For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that
these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that
signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output
is acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is acceptable.
is acceptable.
题目意思:给出一个字符串,要求满足题目所给的三个条件,至少有一个元音,不能连续出现三个元音或三个辅音,不能连续出现2个一样的字符除了“ee”和“oo”,其中aeiou为元音其它全为辅音,让你判断是否合格。
思路:模拟此过程,遍历此字符串。
代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
    char s[30];
    int p1,p2,p3;
    while(gets(s)!=NULL)
    {
        if(strcmp(s, "end") == 0)
        break;
        int i;
        p1=p2=p3=0;
        int cnt1=0,cnt2=0;//用来记录**连续的**辅音或者元音
        int length=strlen(s);
        for(i=0;i<length;i++)
        {
                if(s[i]=='a'||s[i]=='e'||s[i]=='i'||s[i]=='o'||s[i]=='u')
            {
                p1=1;
                cnt1++;//元音加一
                cnt2=0;//辅音清零
            }
            else
            {
                cnt1=0;//辅音清零
                cnt2++;//元音加一
            }
            if(cnt1>=3||cnt2>=3)
                p2=1;
            if(s[i]==s[i+1]&&s[i]!='e'&&s[i]!='o')
                p3=1;
        }
        if(p1==1&&p2==0&&p3==0)
            cout<<"<"<<s<<">"<<" "<<"is acceptable."<<endl;
        else
            cout<<"<"<<s<<">"<<" "<<"is not acceptable."<<endl;
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值