HDU 1195 Open the Lock



Open the Lock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4732    Accepted Submission(s): 2083


Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases.

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4
 

Author
YE, Kai
 

Source


还是一道搜索题。。
题意:变数字开锁。把第一行的数字变到第二行需要最少需要几步
四个位置的数字可以加一或者减一。9加到10时变成1。1减到0时变成9。
也可以交换数字。注意:只能交换左右的位置。第一个位置和最后一个位置不能交换。
上代码

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
using namespace std;
int vis[12][12][12][12];//开个四维数组来存放已经出现过的数。(因为四个位置)
struct node
{
	int num[5];  //存放密码,和原始数。
	int step;
}
;
int bfs(node s,node d)
{
	int i;
	queue<node>q;
    node st,ed,now;
	st=s;
	ed=d;
	st.step=0;
    q.push(st);
	while(!q.empty())
	{
		st=q.front();
		q.pop();
		if(st.num[0]==ed.num[0]&&st.num[1]==ed.num[1]&&st.num[2]==ed.num[2]&&st.num[3]==ed.num[3])//满足开锁条件。
		{
			return st.step;
		}
		for(i=0;i<4;i++)  //这里是每个位置上的数字加一的情况。
		{
			now=st;
			now.num[i]++;
			if(now.num[i]==10)
				now.num[i]=1;
			if(vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]==0)
			{
				vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]=1;
				now.step+=1;
				q.push(now);
			}
		}
		for(i=0;i<4;i++)//这里是减一的情况
		{
			now=st;
			now.num[i]--;
			if(now.num[i]==0)
				now.num[i]=9;
			if(vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]==0)
			{
				vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]=1;
				now.step+=1;
				q.push(now);
			}
		}
		for(i=0;i<3;i++)//这里是交换的情况。
		{
			int t;
			now=st;
			t=now.num[i];
			now.num[i]=now.num[i+1];
			now.num[i+1]=t;
			if(vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]==0)
			{
				vis[now.num[0]][now.num[1]][now.num[2]][now.num[3]]=1;
				now.step+=1;
				q.push(now);
			}
		}
	}
}
int main()
{
	int n,i;
    while(cin>>n)
	{
		while(n--)
		{
			int a1,b1;
			node a,b;
			cin>>a1>>b1;
			memset(vis,0,sizeof(vis));
			for(i=3;i>=0;i--)
			{
				a.num[i]=a1%10;  //把倒过来数字存进结构体数组
				a1/=10;
				b.num[i]=b1%10;//同上
				b1/=10;
			}
			int ans=bfs(a,b);
			printf("%d\n",ans);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值